Bug 18323 - RH 7.0 install faills with anaconda traceback
Summary: RH 7.0 install faills with anaconda traceback
Status: CLOSED DUPLICATE of bug 17791
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-04 12:48 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 18:21:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-04 12:48:37 UTC
Attempting to install Red Hat 7.0 on Dell Latitude laptop with 16GB Fujitsu
hard drive.
Fails with the following message (may not be letter-perfect; had to
transcribe manually):

Traceback (innermost last):
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py",line
20, in run
  rc = selftodo.doInstall ()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in
doInstall
  self.fstab.turnOnSwap()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 406, in
turnOnSwap
  isys.swapon (file)
 File "/usr/lib/anaconda/isys.py", line 142, in swapon
  return_isys.swapon (path)
SystemError: (22, 'Invalid argument')

Please advise.  Similar error occurs with Red Hat 6.2.  Win 2K installs
normally.

Comment 1 Michael Fulbright 2000-10-05 21:54:12 UTC
Could you include the rest of the error message please?

Comment 2 Need Real Name 2000-10-06 09:09:28 UTC
Local variables in innermost frame:
path: /tmp/swap/hda5

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 3 Michael Fulbright 2000-10-06 18:21:35 UTC

*** This bug has been marked as a duplicate of 17791 ***


Note You need to log in before you can comment on or make changes to this bug.