Bug 17791 - Red Hat 7.0 Install Problem Creating Swap
Red Hat 7.0 Install Problem Creating Swap
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
: 18323 18473 18491 18571 18826 20322 20511 21565 21571 21929 23062 23554 23865 23920 24023 24308 24501 25049 31573 34971 35399 47080 53997 82840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-22 11:08 EDT by fred deady
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 16:25:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred deady 2000-09-22 11:08:57 EDT
Traceback (innermost last):
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 
20, in run
rc = self.todo.doInstall ()
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1470, in 
doInstall
self.fstab.turnOnSwap()
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 406, in 
turnOnSwap
isys.swapon (file)
File "/usr/lib/anaconda/isys.py", line 142, in swapon
return _isys.swapon (path)
SystemError: (22, 'Invalid argument')
Local variables in innermost frame:
path: /tmp/swap/hdb5
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6
<failed>
Comment 1 Michael Fulbright 2000-09-25 15:37:22 EDT
Are you doing an install or upgrade?
Comment 2 fred deady 2000-09-25 16:07:21 EDT
I tried both, an install, and an upgrade from Red Hat 6.1. With the same results
it looks like it fails when it tries to newfs the swap partition. The hardware 
is a COMPAQ Deskpro with 550MHz PIII and 128MB memory.
Comment 3 Michael Fulbright 2000-10-04 12:45:24 EDT
Is /tmp a symlink on your system?
Comment 4 fred deady 2000-10-04 13:47:00 EDT
No, /tmp is not a symlink. I've tried the whole disk under one partition /
(with a swap partition), and I've tried two partitions / and /usr, again
with a seperate swap partition.
Comment 5 Michael Fulbright 2000-10-05 14:28:51 EDT
What kind of device is hdb?
Comment 6 Michael Fulbright 2000-10-06 14:20:26 EDT
*** Bug 18491 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2000-10-06 14:21:31 EDT
*** Bug 18323 has been marked as a duplicate of this bug. ***
Comment 8 Need Real Name 2000-10-09 06:55:28 EDT
A comment on 18323: I'm now able to install RH 7.  I think the problem was that
the laptop's hard drive wasn't properly inserted so that disk accesses worked
only intermittently.  Therefore, the anaconda traceback may be pointing to some
kind of disk problem; although if this is the case, a more explicit message
would be helpful.
Comment 9 fred deady 2000-10-09 11:30:22 EDT
My hdb disk is a Maxtor 51024U2.
Comment 10 Michael Fulbright 2000-10-09 13:56:54 EDT
*** Bug 18571 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2000-10-09 14:04:19 EDT
*** Bug 18473 has been marked as a duplicate of this bug. ***
Comment 12 Dave Strickland 2000-10-09 14:19:19 EDT
Here is partitioning scheme I used. When originally setting this up (i.e. when
it
crashed on activating the swap) I chose to format all the linux native
partitions, 
and checked for bad blocks on all of them. I also said yes to the linear option. 
Used fdisk to partition disks, under normal graphical RH7.0 install. 
This didn't happen on any of my other systems that I
upgraded or did raw custom installs on.

Motherboard tyan tiger 133
dual 866Mhz PIII, 1Gb RAM
2 sets of Maxtor 7200rpm 40Gb ATA-66 drives, using ATA-66 80 pin cable, mounted
as master and slave on a single IDE controller.

Disk /dev/hda: 255 heads, 63 sectors, 4982 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      1023   8217216   83  Linux
/dev/hda2          1024      1056    265072+  82  Linux swap
/dev/hda3          1057      3749  21631522+  83  Linux
/dev/hda4          3750      4982   9904072+   5  Extended
/dev/hda5          3750      3782    265041   82  Linux swap
/dev/hda6          3783      3815    265041   82  Linux swap
/dev/hda7          3816      3848    265041   82  Linux swap
/dev/hda8          3849      4982   9108823+  83  Linux


Disk /dev/hdb: 255 heads, 63 sectors, 4982 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1      1023   8217216   83  Linux
/dev/hdb2          1024      2043   8193150   83  Linux
/dev/hdb3          2044      4982  23607517+  83  Linux

BTW: I originally installed RH6.1 on this system, using text mode. I also had a
small swap problem with that as well. I'd asked for two 128M swap partitions,
but when the install was over found only one activated. The other had not
been formated, so I had to manually mkswap etc. With RH6.1 the install didn't
crash though...

Good luck working this one out!
Cheers
Dave
Comment 13 Michael Fulbright 2000-10-18 16:32:24 EDT
*** Bug 18826 has been marked as a duplicate of this bug. ***
Comment 14 Michael Fulbright 2000-11-07 10:17:17 EST
*** Bug 20322 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2000-11-09 16:08:13 EST
*** Bug 20511 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2000-11-15 12:01:09 EST
Thank you for the additional information, passing on to a QA engineer to attempt
to reproduce.
Comment 17 Brock Organ 2000-11-15 12:40:15 EST
hmmm ... I am unable to reproduce this using generic test lab equipment ... this
may be hardware specific ...
Comment 18 Michael Fulbright 2000-12-01 11:21:52 EST
*** Bug 21571 has been marked as a duplicate of this bug. ***
Comment 19 Michael Fulbright 2000-12-01 11:23:25 EST
*** Bug 21565 has been marked as a duplicate of this bug. ***
Comment 20 Need Real Name 2000-12-08 16:13:19 EST
I'm going to try to give you step by step instructions but they are from the 
top of my head since my business partner managed to get it to install.  One 
difference, though I am not at all sure that this cause it to work) is that he 
picked the packages to install rather than letting the default packages be 
installed.

1) Choose Workstation setup.
2) Choose English
3) Choose three button generic mouse.
4) Choose 101 key style keyboard, ignore invalid keys.
5) Choose Generic 1024 * 768 87HZ refresh rate (toward the bottom of the list)
6) Choose Mountain / Denver time zone.
7) Choose GNOME as the desktop
8) Choose Games when selecting the desktop

I think these are all the options that I chose.  One note is that
I checked the path var. and it was : /tmp/swap/hdb6 I believe.


Hope this helps,

-Art
Comment 21 Michael Fulbright 2001-01-03 18:15:45 EST
*** Bug 23062 has been marked as a duplicate of this bug. ***
Comment 22 Michael Fulbright 2001-01-09 11:33:34 EST
*** Bug 23554 has been marked as a duplicate of this bug. ***
Comment 23 Michael Fulbright 2001-01-12 10:22:03 EST
*** Bug 23865 has been marked as a duplicate of this bug. ***
Comment 24 Michael Fulbright 2001-01-15 19:31:02 EST
*** Bug 24023 has been marked as a duplicate of this bug. ***
Comment 25 Michael Fulbright 2001-01-15 19:43:45 EST
*** Bug 23920 has been marked as a duplicate of this bug. ***
Comment 26 Michael Fulbright 2001-01-19 11:29:12 EST
*** Bug 24308 has been marked as a duplicate of this bug. ***
Comment 27 Michael Fulbright 2001-01-19 16:27:14 EST
*** Bug 21929 has been marked as a duplicate of this bug. ***
Comment 28 Michael Fulbright 2001-01-26 11:31:57 EST
*** Bug 24501 has been marked as a duplicate of this bug. ***
Comment 29 Michael Fulbright 2001-01-29 19:45:33 EST
*** Bug 25049 has been marked as a duplicate of this bug. ***
Comment 30 redhatbugzilla 2001-02-09 19:01:45 EST
I have exactly the same problem when trying to install RH7 how I want to. 
Curiously the workstation install works if I just let it decide everything - 
unfortunately, I really don't like the setup it produces...
Comment 31 redhatbugzilla 2001-02-09 21:22:19 EST
I read around the other (duplicate) bugs, and tried installing without telling
it to mount my windows partitions, and it worked fine, so that appears to be the
problem. Will the redhat support people admit to having windows installed on
their test machines? ;-)
Comment 32 Michael Fulbright 2001-02-15 11:48:23 EST
Does everyone seem to agree the common problem here is mounting a FAT partition?
Comment 33 Brock Organ 2001-02-20 17:16:29 EST
dks@pha.jhu.edu partition list above does not have any vfats listed :(

> I read around the other (duplicate) bugs, and tried installing without telling
> it to mount my windows partitions, and it worked fine, so that appears to be 
> the problem. Will the redhat support people admit to having windows installed 
> on their test machines? ;-)

Innocent as charged; after all you can have vfat filesystems on your systems
without having windows installed! ;-0
Comment 34 Joseph S. 2001-03-06 21:48:47 EST
So, is there a fix/solution?  Here is my anacdump.txt:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20,
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win98/c

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 35 Joseph S. 2001-03-07 19:51:10 EST
I was able to install last night.  The problem was, similar to others, Windows
partitions. However, it wasn't the fact that I had Windows partitions.  The
problem was that I was identifying the mount points of my windows partitions
during the install.  Since I already had created my partitions from a previous
install, they were already listed for me to select/identify during the install. 
I simply had to label each partition (/, /usr, /var, /tmp, /home, ).  The
windows partitions were also presented to me.  Previously, I was labelling the
windows partitions /windows/c, /windows/d, /windows/e.  My fix last night was to
simply ignore the windows partitions.  After the install, I simply added my
mount points to /etc/vfstab, created the mount points on the disk, and
everything was happy.
Comment 36 Need Real Name 2001-03-23 20:43:19 EST
I have the same problems, when i install RedHat 7.0 and setup is formating 
swap, i have this message:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'Datei oder Verzeichnis nicht gefunden')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/windows

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
I have M5ATC Mainboard Ati Mach64 Rage II Pentium 233 MMX 8GB and 2GB Harddisks
Comment 37 Brent Fox 2001-04-02 15:30:14 EDT
*** Bug 31573 has been marked as a duplicate of this bug. ***
Comment 38 Matt Smith 2001-04-04 03:51:03 EDT
I experienced the same error when formatting swap, although I was running a 
dual hdd system, i was only installing to one, and not mounting the fat system.
Both hdd's are Maxtor, but i think my problem could be dodgey hardware related, 
as when i tried to re-install, at the disk druid prompt the install couldn't 
access hdb (the one i was trying to install to).
just my $AUD0.02, really not worth much!
Matt
why_not_this@hotmail.com
Comment 39 Brent Fox 2001-04-11 11:29:41 EDT
*** Bug 35399 has been marked as a duplicate of this bug. ***
Comment 40 Brent Fox 2001-04-11 11:43:55 EDT
*** Bug 34971 has been marked as a duplicate of this bug. ***
Comment 41 Brent Fox 2001-04-11 16:25:14 EDT
This issue has been fixed in internal testing trees.  I tested this today.
Comment 42 Brent Fox 2001-07-13 11:56:16 EDT
*** Bug 47080 has been marked as a duplicate of this bug. ***
Comment 43 Brent Fox 2001-09-25 11:03:06 EDT
*** Bug 53997 has been marked as a duplicate of this bug. ***
Comment 44 Philip Le Mesurier 2001-10-04 18:01:19 EDT
Resolution to problem detailed in Bug 53997.

1. Booted from a DOS boot disk and used DEBUG.EXE to remove partition table.
2. Used DOS version of FDISK to create a single FAT32 partition (9.4GB)
3. Formated the partition.
4. Started REDHAT installation from within DOS.
5. Ran default Workstation setup.
NOTE: When I got to the disk partitioning point I noticed that Disk Druid 
reported -7MB (yes, negative) of disk space free. This lead me to think that 
maybe Disk Druid was attempting to create a partition past the end of the disk 
in all my previous, failed attempts. For this reason I decided to leave 100MB 
of disk space unallocated.

Previous attempts had been on a new HDD which had only ever seen REDHAT, so I 
guess there is no way to be certain if steps 1-4 fixed the problem or the 100MB 
unallocated space. Curiosity might force me to investigate this some time :o)

Cheers,
Philip
Comment 45 Michael Fulbright 2003-01-27 12:14:39 EST
*** Bug 82840 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.