Bug 183230 - system-config-kickstart doesn't work with a proxy
system-config-kickstart doesn't work with a proxy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
: 186232 (view as bug list)
Depends On: 185309
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 12:01 EST by oll
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 10:59:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description oll 2006-02-27 12:01:14 EST
Description of problem:

system-config-kickstart doesn't start.
It seems to be a proxy problem since strace tells me it blocks to :

connect(3, {sa_family=AF_INET, sin_port=htons(80),
sin_addr=inet_addr("209.132.177.50")}, 16 <unfinished ...>

Setting the http_proxy variable doesn't help (I'm pretty sure I have the right
http_proxy setting since pirut and yum work well with it)

Version-Release number of selected component (if applicable):

FC5-test3 with the latest "yum update" (execept for kernel)

system-config-kickstart-2.6.6-2


How reproducible:
Always
Comment 1 oll 2006-02-27 12:02:22 EST
Just forgot to add that I'm indeed behind a proxy.
Comment 2 Chris Lumens 2006-03-22 10:00:21 EST
*** Bug 186232 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2006-03-24 11:18:26 EST
Can you confirm that pirut and yum are working, then immediately try
s-c-kickstart and verify it is not working with the same settings?  I'm getting
conflicting reports about the quality of yum's proxy support right now.
Comment 4 stef 2006-03-27 02:12:56 EST
pirut and yum are NOT working for me.

for yum I have to do this to make it work :
[stranche@yuri ~]$ sudo su -
Password:
[root@yuri ~]# !export
export http_proxy=http://proxy:8080
[root@yuri ~]# yum -y upgrade

the line proxy=http://proxy:8080  is present in /etc/yum.conf

for pirut I can't have a working case since the sudo destroy the environnement
variable wich says X is running

[stranche@yuri ~]$ sudo su
[root@yuri stranche]# pirut
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Unable to import modules.  Maybe you're not running under X?

all this seems related to problem encountered in Bug 186054 
Comment 5 oll 2006-03-27 02:24:08 EST
I just check and for me, yum and pirut work perfectly (with the right http_proxy
variable set)
But s-c-k don't

This is an official FC5 with a fresh yum update (system-config-kickstart-2.6.6-2)





Comment 6 stef 2006-03-27 02:29:24 EST
(In reply to comment #5)
> I just check and for me, yum and pirut work perfectly (with the right
http_proxy variable set)

so basicaly this means that as for my case even if proxy=http://proxy:8080  is
present in /etc/yum.conf, you still have to do export
http_proxy=http://proxy:8080 in the console you're running to make it work, right ?
Comment 7 oll 2006-03-28 09:54:34 EST
Until now, I always the http_proxy variable to make it work.
I just tested unsetting http_proxy and adding proxy=http://myproxy:myport in
/etc/yum.conf and , indeed , it doesn't work.
But I'm not sure of the syntax either, since the man page is not very precise
about it.
Comment 8 James Martin 2006-04-04 12:19:52 EDT
I'm having the same problem here.. shouldn't the bug be changed to reflect that
it occurs on fc5 and not just fc5test3?
Comment 9 Chris Lumens 2006-09-15 11:28:13 EDT
Is this still a problem with FC6test3?  s-c-kickstart isn't doing anything
special with yum or networking here, so any proxy problem should be in yum
itself.  There have been a lot of releases since this bug was filed so it's
possible it has been fixed upstream.
Comment 10 James Martin 2006-11-21 09:36:20 EST
Chris,

Seems to work now on FC6.. So long as the http_proxy environment variable is set
or the proxy is defined in gnome.
Comment 11 Chris Lumens 2006-11-21 10:59:21 EST
Thanks for the confirmation.  I'm closing on the basis of comment #10.  It seems
like we should have a better setup for defining proxies for yum in general, but
yum configuration issues are a whole different bug.

Note You need to log in before you can comment on or make changes to this bug.