Bug 186232 - system-config-kickstart unusable if you have a proxy
Summary: system-config-kickstart unusable if you have a proxy
Status: CLOSED DUPLICATE of bug 183230
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-22 13:37 UTC by stef
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 15:00:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description stef 2006-03-22 13:37:06 UTC
Description of problem:

if you network needs a proxy to access internet, you can't use
system-config-kickstart.

both files '/etc/yum.repos.d/fedora-core.repo' and
'/etc/yum.repos.d/fedora-developpement.repo' have the line  enabled=1

-fails when started from the gnome menu (proxy settings done in the preferences
menu)

-fails when started from a sudo :

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

-fails when started from a shell with a su and a 'export
HTTP_PROXY=http://proxy:8080'

[stranche@yuri ~]$ su
Mot de passe :
[root@yuri stranche]# export HTTP_PROXY=http://proxy:8080
[root@yuri stranche]# system-config-kickstart
system-config-kickstart requires either the base or development yum repository
enabled for package selection.  Please enable one of these in /etc/yum.repos.d
and restart the program.
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 82,
in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 137, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 125, in __init__
    self.y = sckYumBase()
  File "/usr/share/system-config-kickstart/packages.py", line 105, in __init__
    sys._exit(1)
AttributeError: 'module' object has no attribute '_exit'


-fails when started from a shell with a su - and a 'export 

[stranche@yuri ~]$ su -
Mot de passe :
[root@yuri ~]# export HTTP_PROXY=http://proxy:8080
[root@yuri ~]# system-config-kickstart
system-config-kickstart requires either the base or development yum repository
enabled for package selection.  Please enable one of these in /etc/yum.repos.d
and restart the program.
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 82,
in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 137, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 125, in __init__
    self.y = sckYumBase()
  File "/usr/share/system-config-kickstart/packages.py", line 105, in __init__
    sys._exit(1)
AttributeError: 'module' object has no attribute '_exit'


Version-Release number of selected component (if applicable):

system-config-kickstart-2.6.6-2

How reproducible:

always

Steps to Reproduce:
1.launch system-config-kickstart from the gnome menu or a shell
2.
3.
  
Actual results:

no way to have the utility starting

Expected results:

utility start to configure a kickstart file

Additional info:

Comment 1 stef 2006-03-22 13:38:20 UTC
tested to work on a system linked directly to a network with no proxy to access
internet

Comment 2 Chris Lumens 2006-03-22 15:00:07 UTC
You shouldn't need to use sudo or su to run it.  It's using consolehelper, which
should handle all the password stuff for you.

*** This bug has been marked as a duplicate of 183230 ***

Comment 3 stef 2006-03-22 16:00:30 UTC
(In reply to comment #2)
> You shouldn't need to use sudo or su to run it.  It's using consolehelper,
which should handle all the password stuff for you.
> 

here are the outputs done as you say as a simple user, the password stuff being
managed by consolehelper.

As you can see without and with the export of http_proxy, no success

[stranche@yuri ~]$ system-config-kickstart
system-config-kickstart requires either the base or development yum repository e
nabled for package selection.  Please enable one of these in /etc/yum.repos.d an
d restart the program.
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 82,
 in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 137, in __init __
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 125, in __init__
    self.y = sckYumBase()
  File "/usr/share/system-config-kickstart/packages.py", line 105, in __init__
    sys._exit(1)
AttributeError: 'module' object has no attribute '_exit'

[stranche@yuri ~]$ export http_proxy=http://proxy:8080

[stranche@yuri ~]$ system-config-kickstart
system-config-kickstart requires either the base or development yum repository e
nabled for package selection.  Please enable one of these in /etc/yum.repos.d an
d restart the program.
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 82,
 in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 137, in __init __
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 125, in __init__
    self.y = sckYumBase()
  File "/usr/share/system-config-kickstart/packages.py", line 105, in __init__
    sys._exit(1)
AttributeError: 'module' object has no attribute '_exit'



Comment 4 James Martin 2006-03-30 15:23:41 UTC
I'm having the exact same problem.. even with the
system-config-kickstart-2.6.6-4 release.  I too require a proxy server. 
Unfortunately I don't have a system I can test that doesn't use a proxy server.
 The error is below:

system-config-kickstart requires either the base or development yum repository
enabled for package selection.  Please enable one of these in /etc/yum.repos.d
and restart the program.
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 80,
in ?
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 137, in __init__
    self.packages_class = packages.Packages(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/packages.py", line 125, in __init__
    self.y = sckYumBase()
  File "/usr/share/system-config-kickstart/packages.py", line 105, in __init__
    sys._exit(1)
AttributeError: 'module' object has no attribute '_exit'

Clearly the necessary yum repo is enabled or else I would never have gotten any
updates to begin with.

Bug owner or clumens, please reopen this bug.



Thanks,

James



Note You need to log in before you can comment on or make changes to this bug.