Bug 183241 - grubby crashes when installing a vanilla kernel
grubby crashes when installing a vanilla kernel
Status: CLOSED DUPLICATE of bug 183010
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 14:15 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 18:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2006-02-27 14:15:18 EST
Description of problem:
Building a vanilla 2.6.16-rc5 and doing a "make install" crashes grubby

Version-Release number of selected component (if applicable):
mkinitrd-5.0.28-1

How reproducible:
Always

Steps to Reproduce:
1. Build kernel
2. "make install"
3.
  
Actual results:
...
if [ -r System.map -a -x /sbin/depmod ]; then /sbin/depmod -ae -F System.map 
2.6.16-rc5; fi
sh /usr/src/linux-2.6.git/arch/i386/boot/install.sh 2.6.16-rc5
arch/i386/boot/bzImage System.map "/boot"
*** glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer: 0xbfebf4f0 ***
======= Backtrace: =========
/lib/libc.so.6(__libc_free+0x17b)[0x5783ef]
/sbin/grubby[0x804fd12]
/sbin/grubby[0x804fe73]
/sbin/grubby[0x8050c9e]
/lib/libc.so.6(__libc_start_main+0xdc)[0x5267a4]
/sbin/grubby[0x804a001]
======= Memory map: ========
004f4000-0050d000 r-xp 00000000 fd:00 102425     /lib/ld-2.3.90.so
0050d000-0050e000 r-xp 00018000 fd:00 102425     /lib/ld-2.3.90.so
0050e000-0050f000 rwxp 00019000 fd:00 102425     /lib/ld-2.3.90.so
00511000-00634000 r-xp 00000000 fd:00 102472     /lib/libc-2.3.90.so
00634000-00637000 r-xp 00122000 fd:00 102472     /lib/libc-2.3.90.so
00637000-00638000 rwxp 00125000 fd:00 102472     /lib/libc-2.3.90.so
00638000-0063b000 rwxp 00638000 00:00 0
00dcf000-00dda000 r-xp 00000000 fd:00 102639     /lib/libgcc_s-4.1.0-20060219.so.1
00dda000-00ddb000 rwxp 0000a000 fd:00 102639     /lib/libgcc_s-4.1.0-20060219.so.1
00fb9000-00fba000 r-xp 00fb9000 00:00 0          [vdso]
08048000-08089000 r-xp 00000000 fd:00 33229      /sbin/grubby
08089000-0808c000 rw-p 00041000 fd:00 33229      /sbin/grubby
0808c000-08094000 rw-p 0808c000 00:00 0
09ffa000-0a056000 rw-p 09ffa000 00:00 0          [heap]
b7fa9000-b7faa000 rw-p b7fa9000 00:00 0
b7fc1000-b7fc2000 rw-p b7fc1000 00:00 0
bfead000-bfec2000 rw-p bfead000 00:00 0          [stack]
/sbin/new-kernel-pkg: line 89:  5905 Aborted                 /sbin/grubby
--add-kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default
$makedefault --title "$title" ${mbkernel:+--add-multiboot="$mbkernel"}
${mbargs:+--mbargs="$mbargs"} --args="root=$rootdevice $kernargs"
--remove-kernel="TITLE=$title"


Expected results:
Installed kernel...

Additional info:
Downgraded to 5.0.27-1 and it works fine.
Comment 1 Horst H. von Brand 2006-02-27 14:35:05 EST
Similar junk got spewed when updating my x86_64 box, so this is not i386 only.
Comment 2 Peter Jones 2006-02-27 18:23:43 EST

*** This bug has been marked as a duplicate of 183010 ***

Note You need to log in before you can comment on or make changes to this bug.