Bug 183312 - glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer
glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer
Status: CLOSED DUPLICATE of bug 183010
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 00:04 EST by petrosyan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 04:29:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2006-02-28 00:04:34 EST
Description of problem:
I get an error message when installing the latest kernel-2.6.15-1.19

Version-Release number of selected component (if applicable):
glibc-2.3.90-38

How reproducible:
always

Steps to Reproduce:
yum install kernel-2.6.15-1.19
  
Actual results:

Downloading Packages:
(1/1): kernel-2.6.15-1.19 100% |=========================|  13 MB    00:58
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: kernel                       ######################### [1/1]
*** glibc detected *** /sbin/grubby: munmap_chunk(): invalid pointer: 0xbfcbea00
 ***
======= Backtrace: =========
/lib/libc.so.6(__libc_free+0x17b)[0x1783ef]
/sbin/grubby[0x804fd12]
/sbin/grubby[0x804fe73]
/sbin/grubby[0x8050c9e]
/lib/libc.so.6(__libc_start_main+0xdc)[0x1267a4]
/sbin/grubby[0x804a001]
======= Memory map: ========
00111000-00234000 r-xp 00000000 fd:00 1175064    /lib/libc-2.3.90.so
00234000-00237000 r-xp 00122000 fd:00 1175064    /lib/libc-2.3.90.so
00237000-00238000 rwxp 00125000 fd:00 1175064    /lib/libc-2.3.90.so
00238000-0023b000 rwxp 00238000 00:00 0
00be0000-00bf9000 r-xp 00000000 fd:00 1175057    /lib/ld-2.3.90.so
00bf9000-00bfa000 r-xp 00018000 fd:00 1175057    /lib/ld-2.3.90.so
00bfa000-00bfb000 rwxp 00019000 fd:00 1175057    /lib/ld-2.3.90.so
00db4000-00db5000 r-xp 00db4000 00:00 0          [vdso]
00fd5000-00fe0000 r-xp 00000000 fd:00 1176839    /lib/libgcc_s-4.1.0-20060219.so .1
00fe0000-00fe1000 rwxp 0000a000 fd:00 1176839    /lib/libgcc_s-4.1.0-20060219.so .1
08048000-08089000 r-xp 00000000 fd:00 1795357    /sbin/grubby
08089000-0808c000 rw-p 00041000 fd:00 1795357    /sbin/grubby
0808c000-08094000 rw-p 0808c000 00:00 0
08437000-08493000 rw-p 08437000 00:00 0          [heap]
b7fb3000-b7fb4000 rw-p b7fb3000 00:00 0
b7fbf000-b7fc0000 rw-p b7fbf000 00:00 0
bfcab000-bfcc0000 rw-p bfcab000 00:00 0          [stack]
/sbin/new-kernel-pkg: line 89:  4194 Aborted                 /sbin/grubby --add-
kernel=$bootPrefix/$kernelName-$version $INITRD --copy-default $makedefault --ti
tle "$title" ${mbkernel:+--add-multiboot="$mbkernel"} ${mbargs:+--mbargs="$mbarg
s"} --args="root=$rootdevice $kernargs" --remove-kernel="TITLE=$title"

Installed: kernel.i686 0:2.6.15-1.1977_FC5
Complete!
Comment 1 petrosyan 2006-02-28 00:05:35 EST
steps to reproduce should be:
Steps to Reproduce:
yum install kernel-2.6.15-1.1977_FC5
Comment 2 Jakub Jelinek 2006-02-28 02:28:05 EST
The above error means that glibc detected a bug in grubby.
Comment 3 Frank Arnold 2006-02-28 04:29:54 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 183010 ***

Note You need to log in before you can comment on or make changes to this bug.