Bug 183320 - traceback trying to deselet an installed package
traceback trying to deselet an installed package
Status: CLOSED DUPLICATE of bug 183310
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-28 01:36 EST by Christopher Aillon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 11:19:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2006-02-28 01:36:57 EST
I tried to uncheck gnome-pilot to uninstall it, and got a traceback:

# rpm -q pirut
pirut-0.9.16-1
# cat pirut.log
Component: Software Manager
Summary: TB6d0a67a4 __init__.py:171:simpleDBInstalled:TypeError: unknown key type

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 151, in
_pkgToggled
    if sel and not self.ayum.simpleDBInstalled(name = pkg):
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 171, in
simpleDBInstalled
    mi = self.ts.ts.dbMatch('name', name)
TypeError: unknown key type

Local variables in innermost frame:
self: <__main__.PackageManager object at 0xb7a8008c>
name: gnome-pilot - 2.0.13-7.fc5.2.1.i386
Comment 1 Bill Nottingham 2006-02-28 11:19:23 EST

*** This bug has been marked as a duplicate of 183310 ***

Note You need to log in before you can comment on or make changes to this bug.