Bug 183332 - tr doesn't seems to be locale sensitive
tr doesn't seems to be locale sensitive
Status: CLOSED DUPLICATE of bug 120933
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 183334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 05:58 EST by Nicolas Scheibling
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 06:34:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of locale problem (25.91 KB, image/png)
2006-02-28 05:58 EST, Nicolas Scheibling
no flags Details

  None (edit)
Description Nicolas Scheibling 2006-02-28 05:58:45 EST
Description of problem:
Using tr to translate accentuated characters to simple characters.


Version-Release number of selected component (if applicable):
rpm -qf /usr/bin/tr
coreutils-5.2.1-48.1

How reproducible:
Everytime using tr with $LANG=fr_FR.UTF-8 
 echo "février"  |  tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ" "aceeeeiioouuACEEEEIIOOUU"
fUevrier


Steps to Reproduce:
1. Verify your locale for me it was LANG=fr_FR.UTF-8 
2. Use tr as expected in the man page tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ"
"aceeeeiioouuACEEEEIIOOUU"
3. 
  
Actual results:
 echo "février"  |  tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ" "aceeeeiioouuACEEEEIIOOUU"
fUevrier


Expected results:
 echo "février"  |  tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ" "aceeeeiioouuACEEEEIIOOUU"
fevrier


Additional info:
Comment 1 Nicolas Scheibling 2006-02-28 05:58:45 EST
Created attachment 125389 [details]
Screenshot of locale problem
Comment 2 Tim Waugh 2006-02-28 06:34:18 EST

*** This bug has been marked as a duplicate of 120933 ***
Comment 3 Tim Waugh 2006-02-28 06:35:06 EST
*** Bug 183334 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.