Bug 183334 - tr doesn't seems to be locale sensitive
tr doesn't seems to be locale sensitive
Status: CLOSED DUPLICATE of bug 183332
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 06:19 EST by Thomas Canniot
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 06:35:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of echo (18.57 KB, image/png)
2006-02-28 06:21 EST, Thomas Canniot
no flags Details

  None (edit)
Description Thomas Canniot 2006-02-28 06:19:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.1) Gecko/20060223 Fedora/1.5.0.1-5 Firefox/1.5.0.1

Description of problem:
Using tr to translate accentuated characters to simple characters.

Version-Release number of selected component (if applicable):
rpm -qf /usr/bin/tr
coreutils-5.93-7.2

How reproducible:
Always

Steps to Reproduce:
1. Verify your locale for me it was LANG=fr_FR.UTF-8 
2. Use tr as expected in the man page tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ"
"aceeeeiioouuACEEEEIIOOUU"
3. 

Actual Results:  echo "février"  |  tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ" "aceeeeiioouuACEEEEIIOOUU"
fUevrier

Expected Results:  echo "février"  |  tr "àçéèêëîïôöùüÂÇÉÈÊËÎÏÔÖÙÜ" "aceeeeiioouuACEEEEIIOOUU"
fevrier

Additional info:
Comment 1 Thomas Canniot 2006-02-28 06:21:14 EST
Created attachment 125391 [details]
Screenshot of echo
Comment 2 Tim Waugh 2006-02-28 06:35:03 EST

*** This bug has been marked as a duplicate of 183332 ***

Note You need to log in before you can comment on or make changes to this bug.