Bug 1833508 - Inspector: Allows users to configure any non-link-local IPV6 address for the provisioning interface
Summary: Inspector: Allows users to configure any non-link-local IPV6 address for the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Stephen Benjamin
QA Contact: Lubov
URL:
Whiteboard:
Depends On: 1836929
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-08 18:49 UTC by OpenShift BugZilla Robot
Modified: 2020-06-23 00:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ironic-inspector-image pull 35 None closed [release-4.4] Bug 1833508: Allow any IPv6 address to be configured for provisioning instead of link local scope 2020-07-20 10:54:52 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:39 UTC

Description OpenShift BugZilla Robot 2020-05-08 18:49:12 UTC
This is a clone of Bug #1833385. This is the description of that bug:
Description of problem:

When using routable IPv6 addresses for the provisioning network. The previous grep command only matched local unicast addresses, this new grep will match any IPv6 address, but the link local scope.

The httpd container keeps waiting for "PROV_IFACE" to be configured otherwise.

Version-Release number of the following components:

openshift-baremetal-install 4.4.0-0.nightly-2020-05-07-005846
built from commit fb65b95076665c794e7c1cc148f56722761d0d31
release image registry.svc.ci.openshift.org/ocp/release@sha256:4aa1a03150d5b185f0dd525d9b3fbd33d98b97a8e2b51fc068bb9a56003fe750

More info here: 

- https://github.com/openshift/ironic-image/pull/78
- https://github.com/metal3-io/ironic-image/pull/153


How reproducible:

Steps to Reproduce:
1. Use the installer to deploy an IPv6 cluster
2. Wait for the Bootstrap VM to boot it up
3. Check logs on podman image "http", it gets stuck on:


Actual results:
http container gets stuck on:
...
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured
...

Expected results:

Additional info:

Gets the right ipv6 configured on the httpd server

Comment 1 Kiran Thyagaraja 2020-05-19 17:04:03 UTC
*** Bug 1836929 has been marked as a duplicate of this bug. ***

Comment 2 Kiran Thyagaraja 2020-05-19 17:12:00 UTC
Juan Parrilla's Patch in progress for upstream bits: https://github.com/metal3-io/ironic-inspector-image/pull/55
cc: jparrill@redhat.com, sasha@redhat.com

Comment 3 Stephen Benjamin 2020-05-20 12:43:48 UTC
Even though you probably want both, the inspector change doesn't depend on ironic-image changes. It complicates the bugzilla automation in GitHub to have that loose dependency made a hard one by setting the field.

Comment 7 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.