Bug 1836929 - Inspector: Allows users to configure any non-link-local IPV6 address for the provisioning interface [NEEDINFO]
Summary: Inspector: Allows users to configure any non-link-local IPV6 address for the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Beth White
QA Contact: Daniel
URL:
Whiteboard:
Depends On:
Blocks: 1833508
TreeView+ depends on / blocked
 
Reported: 2020-05-18 13:59 UTC by Juan Manuel Parrilla Madrid
Modified: 2020-07-13 17:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1833385
Environment:
Last Closed: 2020-07-13 17:39:36 UTC
Target Upstream Version:
dmaizel: needinfo? (jparrill)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ironic-inspector-image pull 34 0 None closed bug 1836929: Allow any IPv6 address to be configured for provisioning instead of link local scope 2020-11-17 01:51:32 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:51 UTC

Description Juan Manuel Parrilla Madrid 2020-05-18 13:59:59 UTC
Description of problem:

When using routable IPv6 addresses for the provisioning network. The previous grep command only matched local unicast addresses, this new grep will match any IPv6 address, but the link local scope.

The ironic-inspector container keeps waiting for "PROV_IFACE" to be configured otherwise.

Version-Release number of the following components:

openshift-baremetal-install 4.5.0-0.nightly-2020-05-18-072156
built from commit be624d9e135d9a86108f7e3e47048f0aa848c3c5
release image registry.svc.ci.openshift.org/ocp/release@sha256:44fa7fa1aa49a75c6e2d13480eecf55a61fd75aa4a60d333331b5517ac6cf05b

How reproducible:

Steps to Reproduce:
1. Use the installer to deploy an IPv6 cluster
2. Wait for the Bootstrap VM to boot it up
3. Check logs on podman image "ironic-inspector", it gets stuck on:


Actual results:
http container gets stuck on:
...
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured                                                                                                                                                                                                                                                                                                                               
Waiting for ens4 interface to be configured
...

Expected results:

Should install in a normal way

Additional info:

BZ created to patch:

- https://github.com/metal3-io/ironic-inspector-image (upstream)
- https://github.com/openshift/ironic-image (downstream)

Comment 1 Juan Manuel Parrilla Madrid 2020-05-19 06:54:27 UTC
Patch in progress for upstream bits: https://github.com/metal3-io/ironic-inspector-image/pull/55

Comment 2 Kiran Thyagaraja 2020-05-19 17:04:03 UTC
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1833508

*** This bug has been marked as a duplicate of bug 1833508 ***

Comment 3 Juan Manuel Parrilla Madrid 2020-05-19 19:50:00 UTC
@kiran Is not duplicated, there is 2 images to be patched, with the other BZ just one image will be patched, I need this to address the patch correctly

Comment 4 Juan Manuel Parrilla Madrid 2020-05-19 19:51:45 UTC
The PR for Downstream bits it here: https://github.com/openshift/ironic-inspector-image/pull/34

Comment 7 Daniel 2020-05-24 14:04:09 UTC
From which registry do you take the "ironic-inspector" image?

Comment 8 errata-xmlrpc 2020-07-13 17:39:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.