Bug 183361 - gtk2 hicolor-icon-theme circular dependency
gtk2 hicolor-icon-theme circular dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hicolor-icon-theme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: 183262
  Show dependency treegraph
 
Reported: 2006-02-28 11:56 EST by Orion Poplawski
Modified: 2013-03-13 00:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 13:19:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-02-28 11:56:57 EST
Description of problem:

> gtk2-2.8.13-1
> -------------
> * Sat Feb 25 2006 Matthias Clasen <mclasen@redhat.com> - 2.8.13-1
> - Update to 2.8.13
> 
> * Fri Feb 24 2006 Ray Strode <rstrode@redhat.com> - 2.8.12-8
> - add dependency on hicolor
> 

This has created a circular dependency with hicolor

#rpm -qp --requires gtk2-2.8.13-1.i386.rpm
/bin/sh
/bin/sh
/bin/sh
atk >= 1.6.0-1
glib2 >= 2.7.1-1
hicolor-icon-theme

# rpm -qp --requires hicolor-icon-theme-0.9-1.noarch.rpm
/bin/sh
/bin/sh
coreutils
coreutils
gtk2 >= 2.6.0

and is breaking Fedora Extras builds
Comment 1 Rex Dieter 2006-02-28 12:28:37 EST
IMO, gtk2' dependancy on hicolor-icon-theme is legit.  It's hicolor's dep on
gtk2 that should be tossed out (and has been, based on hicolor's latest changelog:
* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> 0.9-2
- Remove Prereq on gtk.  Prereq's complicate things,
  and the gtk-update-icon-cache is already protected by
  [ -x  ... ]

)
Comment 2 Orion Poplawski 2006-02-28 12:37:44 EST
Looks like we just need a build pushed.
Comment 3 Rex Dieter 2006-02-28 12:42:08 EST
Yes, please.  (-:
Comment 4 Matthias Clasen 2006-02-28 13:19:47 EST
Should be fixed tomorrow

Note You need to log in before you can comment on or make changes to this bug.