Bug 183262 - kipi-plugins: fc5 rebuild failed
kipi-plugins: fc5 rebuild failed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kipi-plugins (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 183361 183367
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 15:16 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 14:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-02-27 15:16:36 EST
It appears some dependant lib either has bloated .la file and/or has missing
Req: libtool-ltdl-devel

Details:

From:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/3996-kipi-plugins-0.1.0-0.6.rc1.fc5/
/bin/sh ../../libtool --silent --tag=CXX --mode=link g++  -DNDEBUG -DNO_DEBUG
-O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -fno-exceptions -fno-check-new
-fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT
-DQT_NO_TRANSLATION    -o kipiplugin_kameraklient.la -rpath /usr/lib64/kde3
-module -avoid-version -module -no-undefined -Wl,--no-undefined
-Wl,--allow-shlib-undefined   -L/usr/lib64/qt-3.3/lib -L/usr/lib64   
kipiplugin_kameraklient_la.all_cpp.lo  -lkparts -lkdeui -lkipi   -L/usr/lib64
-lgphoto2 -lm -L/usr/lib64 -lgphoto2_port 
/usr/bin/ld: cannot find -lltdl
collect2: ld returned 1 exit status
make[3]: *** [kipiplugin_kameraklient.la] Error 1
make[3]: Leaving directory
`/builddir/build/BUILD/kipi-plugins-0.1.0-rc1/kipi-plugins/kameraklient'
Comment 1 Rex Dieter 2006-02-28 12:24:20 EST
gphoto2 is the culprit (bug #183367).
Comment 2 Rex Dieter 2006-02-28 12:55:15 EST
I'm tempted to simply workaround by adding
BR: libtool-ltdl-devel 
here, but can't since most FE builds are dead due to 
"gtk2/hicolor circular dep" (bug #183361)
Comment 3 Rex Dieter 2006-03-01 10:45:53 EST
Workaround implemented, will keep this open so we'll know when to remove the
hack when gphoto2 is fixed.

Note You need to log in before you can comment on or make changes to this bug.