Bug 183367 - gphoto2: remove .la files
gphoto2: remove .la files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks: 183262
  Show dependency treegraph
 
Reported: 2006-02-28 12:23 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.99-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 02:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-02-28 12:23:29 EST
Main problem is that gphoto2-devel-2.1.99-5.2's /usr/lib/libgphoto2.la contains:
dependency_libs=' /usr/lib/libgphoto2_port.la /usr/lib/libltdl.la -ldl -lexif -lm'
but doesn't
Requires: libtool-ltdl-devel

IMHO, the best solution to avoid the libtool madness is simply to drop all
%{_libdir}/lib*.la
from the gphoto2 packaging.  You could then (theoretically) remove the
Requires: libexif-devel 
too, provided that gphoto2's headers don't reference anything from libexif-devel
(and I'm pretty sure they don't).
Comment 1 Rex Dieter 2006-02-28 13:36:47 EST
Looks like the libexif-devel thing was added due to libtool bloat as well (bug
#135058).

A slightly less obtrusive step than removing the .la files altogether would be
to simply strip out the offending bits from the .la files, using something like:
sed -i -e "s|/usr/lib/libltdl.la||" $RPM_BUILD_ROOT%{_libdir}/lib*.la
sed -i -e "s|-lexif||" $RPM_BUILD_ROOT%{_libdir}/lib*.la
Comment 2 Radek Vokal 2006-03-02 02:48:06 EST
The .la files should be gone, I've realized there's a small typo in the specfile
which doesn't remove the following file. If kipi-plugins doesn't depend on .la
files I fix that in next rawhide update. 

Note You need to log in before you can comment on or make changes to this bug.