Bug 183373 - Traceback when selecting optional packages
Traceback when selecting optional packages
Status: CLOSED DUPLICATE of bug 183310
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 13:08 EST by Luke Macken
Modified: 2016-09-19 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 13:18:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2006-02-28 13:08:40 EST
When selecting any checkbox under the 'Optional Packages' dialog in pirut, the
following trackback occurs:

- - -
Component: Software Manager
Summary: TB6d0a67a4 __init__.py:171:simpleDBInstalled:TypeError: unknown key type

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 155, in
_pkgToggled
    elif self.ayum.simpleDBInstalled(name = pkg):
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 171, in
simpleDBInstalled
    mi = self.ts.ts.dbMatch('name', name)
TypeError: unknown key type

Local variables in innermost frame:
self: <__main__.PackageManager object at 0xb7a7de2c>
name: themes-backgrounds-gnome - 0.4-4.fc5.noarch
- - -

Version-Release number of selected component (if applicable):
pirut-0.9.16-1
Comment 1 Luke Macken 2006-02-28 13:18:23 EST

*** This bug has been marked as a duplicate of 183310 ***

Note You need to log in before you can comment on or make changes to this bug.