Bug 183421 - Kernel Oops when booting with ACPI enabled
Kernel Oops when booting with ACPI enabled
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-02-28 17:35 EST by Mark Arrasmith
Modified: 2015-01-04 17:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-06 12:40:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark Arrasmith 2006-02-28 17:35:21 EST
Description of problem: 
When installing or booting FC5 test3 (FC4.92) on a Gateway M280 laptop I get a 
kernel oops in the ata_piix kernel module.  If I boot with acpi=off I can 
install and boot the system.  Basically I get ... 
"Unable to handle kernel NULL pointer dereference at virtual address 00000000" 
During the sata probe.  This seems to be the same bug reference at the Kernel 
mailing list ... http://lkml.org/lkml/2006/1/16/106 though I haven't had the 
system long enough to compile the -linus kernel. 
Version-Release number of selected component (if applicable): 
rpm -q kernel gives kernel-2.6.15-1.1991_FC5 
How reproducible: 
Every boot single boot. 
Steps to Reproduce: 
1. make sure acpi=off is not in the kernel boot line for grub 
2. boot 
Actual results: 
kernel oops 
Expected results: 
It should boot normally. 
Additional info:  
From what is stated on the lkml I'm also guessing that the laptop's bios is 
not setting up the SATA ports correctly.  So I installed the latest bios 
(62.05) from Gateway, but it didn't help.   
I have booted other kernels (specifically 2.6.16-rc4 via Ark Linux) with ACPI.  
Though I have the same SATA problem with the 2.6.9 kernels from RHE 4 and all 
the 2.6.x kernels from FC4.
Comment 1 Mark Arrasmith 2006-03-01 09:46:58 EST
I downloaded a stock from kernel.org and compiled it.  The SATA 
ata_piix driver did not oops during boot with the stock kernel.  I'll take the 
fc5 kernel src.rpm, do a build prep, and then compare the stock ata_piix 
versus the fc5 version.  Maybe that will give me some insight into what is 
going on with the kernel oops. 
- mark 
Comment 2 Dave Jones 2006-03-01 23:48:53 EST
the fc5 kernel is based on 2.6.16rc5-git right now, which is way different to, which could explain why your self-built kernel worked.

Comment 3 Mark Arrasmith 2006-03-02 02:00:31 EST
> way different ...  
:)  After grabbing the src.rpm and comparing ... Yeah ... I have no idea where 
to start on the differences of the scsi directory and ata_piix.  
But, I tried ArkLinux 2006.1 beta on this laptop.  It booted a 2.6.16-rc4 
kernel just fine.  I didn't look at what all patches or which tree they were 
using before moving on to try FC 4.92 though. 
Right now I'm glad I've gotten working (though I have to not use 
SELinux).  The latest kernel-2.6.15-1.1996_FC5 seems to have just broke the 
ipw2200 driver.  Anyway I'll grab 2.6.16rc5-git and see what happens. 
- mark 
Comment 4 Mark Arrasmith 2006-03-02 11:35:09 EST
OK, using the 1.1996 src.rpm from fedora development I extracted the 2.6.15 
source.  And I then patched it with patch-2.6.16-rc5.bz2 and with 
patch-2.6.16-rc5-git3.bz2 which were in the src.rpm.  Using the same .config 
file from my previous build of I now have a booting laptop with ACPI 
+ SATA + ipw2200 ( using it right now in fact ).  None of which worked 
together with the 1.1996 kernel. 
So ... which of the other 120 patches should I apply or not apply to try and 
narrow down where my problem is nested at? 
- mark 
Comment 5 Mark Arrasmith 2006-03-03 15:05:44 EST
Don't know if I want to hit my head on the table now though ... 
Starting with the 1.2008 src.rpm I commented out the patches from the spec 
file and did a rpmbuild -bp.  I then applied batches of patches to make sure 
that they were not the "bug".  Anyway, it came down to patches 200, 201, or 
205.  Realizing that 201 turns off APIC and LAPIC I took a quick guess.  
Booting the stock 1.2008 kernel with apic=on and lapic=on ... NO KERNEL OOPS! 
So on this laptop APIC and LAPIC are needed.  Has the apic-off-by-default 
patch been applied to the enterprise kernels?  I'll try to boot the CentOS 4.2 
and FC 4 install CD's to check if apic=on lapic=on allows the install to start 
I really can't say anything about the patch itself (that is for people who 
know what they are doing).  If it is "buggy", should APIC and LAPIC default to 
on, or what. 
One last question: when did the apic-off-by-default patch get put into the 
- mark 
Comment 6 Dave Jones 2006-03-04 16:35:48 EST
I'll drop that patch for the next build (and final release of fc5)
thanks for your detective work on this.
Comment 7 Konrad Rzeszutek 2006-03-06 10:40:21 EST
Just to be completly sure, the rawhide would now auto-detect if the BIOS has
APIC enabled, and if so, turn the APIC on, if required.
Comment 8 Dave Jones 2006-03-06 12:40:31 EST
Should be fixed in the kernel at http://people.redhat.com/davej/kernels/Fedora/devel
Comment 9 Dave Jones 2006-03-06 15:53:55 EST
Konrad, yes,that's correct. We'll blacklist any boxes that need it explicitly
disabled as we come across them (which hopefully should be few)
Comment 10 Mark Arrasmith 2006-03-06 16:23:26 EST
To Dave: Thanks.  The 2.6.15-1.2016_FC5 kernel works perfectly for my laptop 
(Gateway M280 Tablet).  Yeah!  Now, onto fix the Xorg FinePoint tablet driver. 
- mark 

Note You need to log in before you can comment on or make changes to this bug.