Bug 183457 - greek letters not displayed : make el_GR langpack require a greek glyph providing font
Summary: greek letters not displayed : make el_GR langpack require a greek glyph provi...
Status: CLOSED DUPLICATE of bug 170218
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 4
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-01 09:43 UTC by Vlado Potisk
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.0.1.1-5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 12:36:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RTF document in english and greek (49.50 KB, application/octet-stream)
2006-03-01 09:43 UTC, Vlado Potisk
no flags Details
how about this (108.58 KB, image/png)
2006-03-01 09:53 UTC, Caolan McNamara
no flags Details
screenshot (43.37 KB, image/png)
2006-03-01 10:08 UTC, Vlado Potisk
no flags Details
browser screenshot (44.35 KB, image/png)
2006-03-13 11:47 UTC, Vlado Potisk
no flags Details

Description Vlado Potisk 2006-03-01 09:43:24 UTC
The OO software does not display characters of the greek alphabet. I am unable
to read documents containing sections written in greek language (sample document
attached) and I am unable to write a document containing greek text.

Greek characters are shown as whitespace or as rectangles with Bitstream Vera
Sans font. In this case (Bitstream Vera) the letter PI is displayed correctly
and with the Courier font six other letters are displayed correctly, but the
major part is unreadable.

To write I'm using the greek keyboard from KDE, it works in kmail, mozilla, but
not in OO.

Comment 1 Vlado Potisk 2006-03-01 09:43:24 UTC
Created attachment 125455 [details]
RTF document in english and greek

Comment 2 Caolan McNamara 2006-03-01 09:53:24 UTC
Created attachment 125457 [details]
how about this

Does this look right ? Or is the problem visible in this screenshot ?

Comment 3 Vlado Potisk 2006-03-01 10:08:41 UTC
Created attachment 125458 [details]
screenshot

Comment 4 Vlado Potisk 2006-03-01 10:10:09 UTC
Your screenshot looks good. I have attached screenshot from my system.

Comment 5 Caolan McNamara 2006-03-01 10:17:42 UTC
righteo, my screenshot is fc5 with 2.0.2. I need to investigate fc4 and see if
this works now because of an additional font installed, or because of our extra
fontconfig integration in 2.0.2 and if a backport to fc4 makes sense/safe

Comment 6 Caolan McNamara 2006-03-06 10:20:14 UTC
Works for me with 2.0.1.1-5.1 from fc4 updates on an up-to-date fc4 box. 

If your problems persist perhaps it's due to glyph fallback not having enough
fonts to work with to find a good replacement.

Comment 7 Vlado Potisk 2006-03-06 15:51:30 UTC
Could you please be so kind and list the font packages you have on your system ?

My software is the same, i.e. version 2.0.1.1-5.1 running on an up-to-date fc4
system. I have installed every fc4 package having 'font' in its name except the
Asian ones.


Comment 8 Caolan McNamara 2006-03-13 09:34:52 UTC
Damn, I see this now. Actually I had java's jdk installed in /opt/jre1.5.0_05
and my default /etc/fonts/fonts.conf includes /opt/jre1.5.0_05/libs/fonts in its
path, which is why it worked for me :-(

So as a quick fix you can get that jre from sun and use its fonts.

Comment 9 Caolan McNamara 2006-03-13 10:12:11 UTC
Well that's odd. The best font that we ship with for greek coverage appears to
be fonts-chinese :-).

So...

> yum -y install fonts-chinese

and you'll be able to read the document.

I'll make the greek langpack depend on this font so greek users will be able to
read stuff out of the box in the future.

Comment 10 Vlado Potisk 2006-03-13 11:45:34 UTC
> yum -y install fonts-chinese

This could be one of the funniest bugfixes ever ! Unfortunately it is not good
enough to be usable. Please don't make the dependency.

Accented characters are completely missing (and there is one such character in
every Greek word that has two or more syllables) and the letter spacing is odd,
the words are not recognizable as such.

Here is a workaround that works: start the oowriter, load the file, save it in
HTML format and then use a browser to read it. I'm attaching a screenshot. Would
it be possible for the OpenOffice to use the same Greek font that the browser is
using ? That font is fine.

(I haven't tried the Sun JRE fonts yet)

Comment 11 Vlado Potisk 2006-03-13 11:47:02 UTC
Created attachment 126031 [details]
browser screenshot

Comment 12 Caolan McNamara 2006-03-13 12:36:04 UTC
That looks like a bitmap font, not a Type1 or TTF, so not really useful to OOo :-(

Try and print from firefox and you should get a total mess again, or print to
file and use evince on it.

Basically this isn't an OOo problem, we just don't seem to have a proper greek
font, and end up stiching together glyphs from random fonts which only intend
their greek characters to be used in equations. 

See the discussion at bug 158032. DejaVu fonts in extras (and some other greek
fonts) exist, try and install dejavu or one of the fonts listed at 158032. 

*** This bug has been marked as a duplicate of 170218 ***

Comment 13 Vlado Potisk 2006-03-13 15:42:07 UTC
Yes, the dejavu-fonts solved my problem, thank you.


Note You need to log in before you can comment on or make changes to this bug.