Bug 1834934 - Upgrade from OCS-4.3 to OCS-4.4 failed
Summary: Upgrade from OCS-4.3 to OCS-4.4 failed
Keywords:
Status: CLOSED DUPLICATE of bug 1834936
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.5.0
Assignee: Vu Dinh
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-12 17:18 UTC by Jose A. Rivera
Modified: 2020-05-21 13:58 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1823937
Environment:
Last Closed: 2020-05-21 13:58:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Petr Balogh 2020-05-12 19:00:05 UTC
@Vu, as we discussed offline trying to reproduce it once more on OCP 4.3 here as last week we didn't see this issue in OCP 4.3:

https://ocs4-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/qe-deploy-ocs-cluster/7469/console

the access to the cluster should be available in the job description:
https://ocs4-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/qe-deploy-ocs-cluster/7469/

Currently it is installing OCS 4.3 and will continue with upgrade.


Please do not do any changes in the cluster now as it can break the automation. You can just connect to check the progress, it should be OK if no changes made in cluster ;)

Once you will see from console output of the job that it's paused and waiting for user input you can do any disruptive operations or changes in cluster.


I can ping you if I will be still online, otherwise we will need to count only on collected data from job itself which I will be available after the job will finish here: 
http://magna002.ceph.redhat.com/ocsci-jenkins/openshift-clusters/jnk-ai3c33-ua/jnk-ai3c33-ua_20200512T181114/logs/

Thanks.

Comment 2 Petr Balogh 2020-05-12 21:11:46 UTC
Looks like upgrade started OK on OCP 4.3 but then we hit another noobaa related issue. But OLM started rolling upgrade of OCS fine in the job mentioned above.
If someone is curious about must gather logs from OCP 4.3 execution they are here:
http://magna002.ceph.redhat.com/ocsci-jenkins/openshift-clusters/jnk-ai3c33-ua/jnk-ai3c33-ua_20200512T181114/logs/failed_testcase_ocs_logs_1589311239/test_upgrade_ocs_logs/

Comment 3 Nimrod Becker 2020-05-14 09:30:35 UTC
We are looking at the issue on noobaa, however this is does prevent the progress on this BZ right ?

Comment 4 Michael Adam 2020-05-14 12:28:42 UTC
fixing direction of BZ dependency.. ;-)

Comment 5 Petr Balogh 2020-05-14 20:39:21 UTC
Nimrod on OCP 4.4 we cannot even start upgrade cause of OLM issue.
On OCP 4.3 the upgrade to OCS 4.4 will start OK, but then it's failing on noobaa BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=1835125

So basically we cannot really confirm that upgrade working even on OCP 4.3.
But actually without running any pre upgrade tests we passed the whole upgrade.

Comment 6 Evan Cordell 2020-05-21 13:58:37 UTC

*** This bug has been marked as a duplicate of bug 1834936 ***


Note You need to log in before you can comment on or make changes to this bug.