Bug 1835170 - 'Edit Application Grouping' kebab action is not available for DC
Summary: 'Edit Application Grouping' kebab action is not available for DC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 10:00 UTC by Yadan Pei
Modified: 2020-07-13 17:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
No 'Edit Application Grouping' kebab menu (339.00 KB, image/png)
2020-06-02 07:08 UTC, Yadan Pei
no flags Details
Topology Side Panel (170.07 KB, image/png)
2020-06-02 10:55 UTC, Jeff Phillips
no flags Details
There is Edit Application Grouping menu in Topology view (452.71 KB, image/png)
2020-06-03 02:13 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5603 0 None closed Bug 1835170: Allow Edit Application Grouping in topology side panel 2020-06-24 02:31:09 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:38 UTC

Description Yadan Pei 2020-05-13 10:00:15 UTC
Description of problem:
kebab action 'Edit Application Grouping' is deleted for DC

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-12-195228

How reproducible:
Always

Steps to Reproduce:
1. create application
2. view DC at Projects -> Workloads 
3. click Actions button to view available action menus for DC

Actual results:
3. No 'Edit Application Grouping' as in 4.4

Expected results:
3. I'm not sure if this is removed by purpose but we didn't find PR removing it 

Additional info:

Comment 1 Robb Hamilton 2020-05-13 18:52:46 UTC
Reassigning to Vikram as git history reveals he's the one most recently working on the DC actions.

Comment 5 Yadan Pei 2020-06-01 02:47:54 UTC
Hi Jeff,

Reading the fix PR, does it mean `Edit Application Grouping` is customized action menu and it only appears when certain conditions are met? Could you please tell me how can I enable/see `Edit Application Grouping` menu for DC? 


  let customActions: KebabAction[] = null;
  if (!item.operatorBackedService) {
    customActions = [ModifyApplication];
  }


I was checking the bug against 4.5.0-0.nightly-2020-05-30-025738 which already includes the fix PR

# oc adm release info registry.svc.ci.openshift.org/ocp/release:4.5.0-0.nightly-2020-05-30-025738 --pullspecs | grep console
  console                                        quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:57db33cc2bc1d8b23e0bebe311fb1315b7f8b6244c5dbc47d6e1273e0f0b5bfb
  console-operator                               quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:56daabfd30148e9222a41aa153ea3d3c96b9f0d3761122f3d4ce2b1962f86526
# oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:57db33cc2bc1d8b23e0bebe311fb1315b7f8b6244c5dbc47d6e1273e0f0b5bfb | grep commit
             io.openshift.build.commit.id=246f7fd82ffb8018d5e6993b176b36a5f8cb2840
# git log 246f7fd82ffb8018d5e6993b176b36a5f8cb2840 | grep '#5603'
    Merge pull request #5603 from jeff-phillips-18/sidebar-menus

Comment 6 Jeff Phillips 2020-06-01 12:13:44 UTC
Hi Yadan,

You should see this action for any DCs in the side panel (and context menu) which are not Operator Backed nor part of a Helm chart.

Comment 7 Yadan Pei 2020-06-02 07:08:53 UTC
Created attachment 1694319 [details]
No 'Edit Application Grouping' kebab menu

Comment 8 Yadan Pei 2020-06-02 07:09:41 UTC
Hi Jeff, 

I didn't see `Edit Application Grouping` menu for DC(see attached screenshot), assigning back

Comment 9 Jeff Phillips 2020-06-02 10:55:02 UTC
Created attachment 1694381 [details]
Topology Side Panel

Comment 10 Jeff Phillips 2020-06-02 10:56:29 UTC
Hi Yadan,

The item is only available from the Topology view. From the side panel when selecting a DC or from the context menu (right click on a DC).

Comment 11 Yaacov Zamir 2020-06-02 15:34:40 UTC
Hi all it got into the VM actiosns:
https://bugzilla.redhat.com/show_bug.cgi?id=1842857

is this intentional ?

Comment 12 Jeff Phillips 2020-06-02 15:48:15 UTC
Hi Yaacov,

It should have only been added to the side panel and context menu. This is a separate issue that I and address in https://bugzilla.redhat.com/show_bug.cgi?id=1842857

Comment 13 Yadan Pei 2020-06-03 02:12:40 UTC
Thanks Jeff,

Moving to VERIFIED since I can see `Edit Application Grouping` menu in Topology view

Comment 14 Yadan Pei 2020-06-03 02:13:16 UTC
Created attachment 1694679 [details]
There is Edit Application Grouping menu in Topology view

Comment 15 errata-xmlrpc 2020-07-13 17:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.