Bug 1842857 - Edit application grouping is displayed as the first VM action
Summary: Edit application grouping is displayed as the first VM action
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Jeff Phillips
QA Contact: Guohua Ouyang
URL:
Whiteboard:
: 1843753 (view as bug list)
Depends On:
Blocks: 1843552
TreeView+ depends on / blocked
 
Reported: 2020-06-02 08:44 UTC by Radim Hrazdil
Modified: 2020-10-27 16:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:03:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (31.49 KB, image/png)
2020-06-02 08:44 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5654 0 None closed Bug 1842857: Only show Edit Grouping action for VMs in topology view 2020-07-22 00:03:38 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:04:20 UTC

Description Radim Hrazdil 2020-06-02 08:44:18 UTC
Created attachment 1694351 [details]
screenshot

Description of problem:
VM action dropdown has 'Edit application grouping' action displayed as the first option.



Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1. Open VM action dropdown

Comment 1 Yaacov Zamir 2020-06-02 13:02:22 UTC
Targeting 4.6, this looks very high profile, we may consider backporting

Comment 2 Yaacov Zamir 2020-06-02 15:34:50 UTC
Note:

I think it was added by mistake with the fix for
https://bugzilla.redhat.com/show_bug.cgi?id=1835170

Comment 3 Yaacov Zamir 2020-06-02 15:39:57 UTC
Note II:
a - Sorry, not added, just moved to the top (merged 5 days ago):
    https://github.com/openshift/console/pull/5603/files#diff-e1ea60ed2e820073acdfd59753ed6636R211

b - Asked on https://bugzilla.redhat.com/show_bug.cgi?id=1835170 if this is intentional.
    Will update here when get answer.

Comment 4 Yaacov Zamir 2020-06-02 15:54:49 UTC
Thanks Jeff

Comment 7 Guohua Ouyang 2020-06-04 07:57:14 UTC
*** Bug 1843753 has been marked as a duplicate of this bug. ***

Comment 8 Guohua Ouyang 2020-07-02 03:52:21 UTC
The 'Edit application grouping' isn't showing in kebab-button and actions-menu-button any more.
But the fix says "Only show Edit Grouping action for VMs in topology view", what's the "topology view"?

Comment 9 Yaacov Zamir 2020-07-08 07:09:50 UTC
> what's the "topology view"?

Topolgy view is a view in the dev-console showing project items in a graphical view of the topology.

To see the topology view vm menu:
1. choose "Developer" context.
2. choose topology in the left menu bar.
3. choose a project with vms
4. right click on a vm icon.

Comment 10 Guohua Ouyang 2020-07-08 07:18:04 UTC
verified 'Edit application grouping' is only in topology view, not in vm kebab-button and actions-menu-button in normal view.

Comment 12 errata-xmlrpc 2020-10-27 16:03:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.