Bug 183521 - xkeyboard-config xkb package breaks vt switching
xkeyboard-config xkb package breaks vt switching
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 183608 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-03-01 13:29 EST by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 14:03:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Package that should fix the problem (289.12 KB, application/x-redhat-package-manager)
2006-03-01 14:06 EST, Ray Strode [halfline]
no flags Details

  None (edit)
Description Jeremy Katz 2006-03-01 13:29:07 EST
VT switching with xorg-x11-xkbdata-1.0.5 is broken.  In Xorg.0.log is
 (WW) Couldn't load XKB keymap, falling back to pre-XKB keymap

Also, running something like 'setxkbmap us' fails with:
 Couldn't interpret _XKB_RULES_NAMES property
 Use defaults: rules - 'xorg' model - 'pc101' layout - 'us'
 Couldn't find rules file (xorg)

It looks like there's no /usr/share/X11/xkb/rules/xorg which is being expected
by setxkbmap and probably the X server.
Comment 1 Ray Strode [halfline] 2006-03-01 13:38:17 EST
it looks like the package is missing the compat symlink.  I think there is a
configure option to turn it on.
Comment 2 Kjartan Maraas 2006-03-01 13:40:58 EST
I also lost my norwegian keyboard layout when updating to todays rawhide packages
Comment 3 Jason Vas Dias 2006-03-01 13:46:18 EST
I've also reproduced this problem with xorg-x11-xkbdata-1.0.5 - 
unable to switch VTs with <ALT>+<Fn> keystroke.  
Reverting to xorg-x11-xkbdata-1.0.4 and restarting X fixed the problem for me.
Comment 4 Michal Jaegermann 2006-03-01 13:53:15 EST
Actually from what I see xorg-x11-xkbdata-1.0.5 breaks much more than vt
switching.  On my machine functions keys do not work, none of shifted keys
from the top row works, keys {, }, |, <, >, ? do not work, and more ....

Reverting to xorg-x11-xkbdata-1.0.4, which I was still able to find on
some remote server, restores sanity.

Various /usr/share/X11/xkb/rules/*.lst also vanished.  No idea what will be
affected by that.
Comment 5 Ray Strode [halfline] 2006-03-01 14:03:17 EST
should be fixed in tomorrow's rawhide.
Comment 6 Ray Strode [halfline] 2006-03-01 14:06:59 EST
Created attachment 125486 [details]
Package that should fix the problem

For those who don't want to wait until tomorrow, you can install this package
Comment 7 Mike A. Harris 2006-03-01 14:21:50 EST
(In reply to comment #4)
> Actually from what I see xorg-x11-xkbdata-1.0.5 breaks much more than vt
> switching.  On my machine functions keys do not work, none of shifted keys
> from the top row works, keys {, }, |, <, >, ? do not work, and more ....
[SNIP]
> Various /usr/share/X11/xkb/rules/*.lst also vanished.  No idea what will be
> affected by that.

Yep, at least some of that should be fixed in the latest package now.  There
are likely to be some regressions yet to find/fix though.  If you encounter
any problems with xkeyboard-config, please report them in bugzilla ASAP,
so we can try to fix as many as possible before FC5.  xkeyboard-config
is the only maintained xkbdata set with an active upstream right now, so
even if there are some temporary glitches, everyone benefits from the
switch in the mid/long term.

There are many fixes in CVS also, so I'll be cherrypicking individual fixes
between now and FC5 final.

Feel free to drop in #fedora-devel or #fedora-x on freenode IRC also for
realtime.

Also, thanks for the feedback.
Comment 8 Pierre Ossman 2006-03-03 04:21:27 EST
*** Bug 183608 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.