Bug 1835457 - Support populating introspection data from annotation
Summary: Support populating introspection data from annotation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Stephen Benjamin
QA Contact: Lubov
URL:
Whiteboard:
Depends On:
Blocks: 1843230
TreeView+ depends on / blocked
 
Reported: 2020-05-13 20:04 UTC by Stephen Benjamin
Modified: 2020-07-13 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1843230 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:38:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-operator pull 68 0 None closed Bug 1835457: Put BMH status in annotation while reconciliation 2020-11-10 21:41:05 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:52 UTC

Description Stephen Benjamin 2020-05-13 20:04:43 UTC
Upstream added support to populate introspection via annotation, we need to backport this into baremetal-operator so we can populate masters IP information to make the node/machine link.

Comment 4 Stephen Benjamin 2020-06-03 11:48:27 UTC
This is installer.  "Bare Metal Hardware Provisioning" is only HWManagement if it's in the ironic subcomponent.

Comment 5 Lubov 2020-06-04 07:08:19 UTC
Please, provide specification/guide to test this one

Comment 6 Lubov 2020-06-09 08:05:02 UTC
I think verification of https://bugzilla.redhat.com/show_bug.cgi?id=1844205 includes verification of this bug. Do you agree?

Comment 7 Steven Hardy 2020-06-10 13:11:00 UTC
(In reply to Lubov from comment #6)
> I think verification of https://bugzilla.redhat.com/show_bug.cgi?id=1844205
> includes verification of this bug. Do you agree?

No 1844205 was a regression caused but the implementation of this I believe, but you can validate this by inspecting any of the masters in a recent deployment, e.g:

  oc describe bmh ostest-master-0 -n openshift-machine-api

Should show the following annotation:

  Annotations:  baremetalhost.metal3.io/status:
                {
                  "hardware": {
                    "systemVendor": {
                      "manufacturer": "Red Hat",
                      "productName": "KVM",
                      "serialNumber": ""
                    },
                    "firmware": {
                      "bios": {
                        "date": "",
                        "vendor": "",
                        "version": ""
                      }
                    },
                    "ramMebibytes": 16384,
                    "nics": [
                      {
                        "name": "enp2s0",
                        "model": "0x1af4 0x0001",
                        "mac": "00:f0:8e:ee:8a:7f",
                        "ip": "fd2e:6f44:5dd8:c956::14",
                        "speedGbps": 0,
                        "vlanId": 0,
                        "pxe": false
                      },
                      {
                        "name": "enp1s0",
                        "model": "0x1af4 0x0001",
                        "mac": "00:f0:8e:ee:8a:7d",
                        "ip": "fd00:1101::5a",
                        "speedGbps": 0,
                        "vlanId": 0,
                        "pxe": true
                      }
                    ],
  ...


Then in the Status->Hardware field we should see corresponding data e.g:

    Hostname:     master-0.ostest.test.metalkube.org
    Nics:
      Ip:           fd2e:6f44:5dd8:c956::14
      Mac:          00:f0:8e:ee:8a:7f
      Model:        0x1af4 0x0001
      Name:         enp2s0
      Pxe:          false
      Speed Gbps:   0
      Vlan Id:      0
      Ip:           fd00:1101::5a
      Mac:          00:f0:8e:ee:8a:7d
      Model:        0x1af4 0x0001
      Name:         enp1s0
      Pxe:          true
      Speed Gbps:   0
      Vlan Id:      0
    Ram Mebibytes:  16384
    Storage:
      Hctl:           0:0:0:0
      Model:          QEMU HARDDISK
      Name:           /dev/sda
      Rotational:     true
      Serial Number:  drive-scsi0-0-0-0
      Size Bytes:     21474836480
      Vendor:         QEMU
    System Vendor:
      Manufacturer:   Red Hat
      Product Name:   KVM
      Serial Number:

Comment 8 Lubov 2020-06-10 13:32:13 UTC
Server 4.5.0-0.nightly-2020-06-09-223121 - shown as expected

Comment 9 errata-xmlrpc 2020-07-13 17:38:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.