Bug 1844205 - control plane hosts no longer adopted in Ironic
Summary: control plane hosts no longer adopted in Ironic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Doug Hellmann
QA Contact: Lubov
URL:
Whiteboard:
Depends On: 1843950
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 19:22 UTC by Doug Hellmann
Modified: 2020-07-13 17:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1843950
Environment:
Last Closed: 2020-07-13 17:43:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-operator pull 74 0 None closed [release-4.5] Bug 1844205: remove infinite reconcile loop when fetching status annotation 2020-11-18 13:22:05 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:43:38 UTC

Description Doug Hellmann 2020-06-04 19:22:33 UTC
+++ This bug was initially created as a clone of Bug #1843950 +++

Description of problem:

BareMetalHosts for the control plane no longer get adopted by Ironic, nor do they show "externally provisioned" as their status:

NAMESPACE               NAME              STATUS   PROVISIONING STATUS   CONSUMER                BMC                                    HARDWARE PROFILE   ONLINE   ERROR
openshift-machine-api   ostest-master-0                                  ostest-master-0         ipmi://[fd2e:6f44:5dd8:c956::1]:6230                      true     
openshift-machine-api   ostest-master-1                                  ostest-master-1         ipmi://[fd2e:6f44:5dd8:c956::1]:6231                      true     
openshift-machine-api   ostest-master-2                                  ostest-master-2         ipmi://[fd2e:6f44:5dd8:c956::1]:6232                      true  
$ openstack baremetal node list
+--------------------------------------+-----------------+--------------------------------------+-------------+--------------------+-------------+
| UUID                                 | Name            | Instance UUID                        | Power State | Provisioning State | Maintenance |
+--------------------------------------+-----------------+--------------------------------------+-------------+--------------------+-------------+
| cbd1083d-8cfc-4ee5-90ea-c401e4417cb3 | ostest-worker-0 | fe83b857-e323-4b6b-a097-e991d2dcaeac | power on    | active             | False       |
| e3917506-0e1e-4490-ac63-ebd1a7966a0a | ostest-worker-1 | 9d59ea8a-b42e-493f-9574-699abad4a22a | power on    | active             | False       |
+--------------------------------------+-----------------+--------------------------------------+-------------+--------------------+-------------+


Version-Release number of selected component (if applicable):

Latest 4.6 CI build

How reproducible:

Always

Steps to Reproduce:
1. Install OpenShift on baremetal IPI

Actual results:

Masters are online, but don't show externally provisioned anymore, and they don't get adopted into Ironic.

Expected results:

Masters show externally provisioned, and end up in the Ironic database.

Additional info:

--- Additional comment from Stephen Benjamin on 2020-06-04 13:45:20 UTC ---

We also see this in 4.5, so it likely needs fixing and then backported.

--- Additional comment from Doug Hellmann on 2020-06-04 18:06:20 UTC ---

https://github.com/metal3-io/baremetal-operator/pull/546 addresses this upstream in the baremetal-operator.

Comment 3 Lubov 2020-06-09 08:15:40 UTC
Client Version: 4.5.0-0.nightly-2020-06-05-214616
Server Version: 4.5.0-0.nightly-2020-06-09-030606
Kubernetes Version: v1.18.3+a637491

NAME                   STATUS   PROVISIONING STATUS      CONSUMER                            BMC                                                                                    HARDWARE PROFILE   ONLINE   ERROR
openshift-master-0-0   OK       externally provisioned   ocp-edge-cluster-0-master-0         redfish://192.168.123.1:8000/redfish/v1/Systems/98c337f1-fa03-4ea6-a759-778e69b1bc8e                      true     
openshift-master-0-1   OK       externally provisioned   ocp-edge-cluster-0-master-1         redfish://192.168.123.1:8000/redfish/v1/Systems/2b1a821f-4625-4ef6-a4c7-915b56c4c168                      true     
openshift-master-0-2   OK       externally provisioned   ocp-edge-cluster-0-master-2         redfish://192.168.123.1:8000/redfish/v1/Systems/e48dc381-78fe-4469-8f60-3f9a2ef05c5c                      true

Comment 4 Lubov 2020-06-09 09:36:14 UTC
$ openstack baremetal node list
+--------------------------------------+----------------------+--------------------------------------+-------------+--------------------+-------------+
| UUID                                 | Name                 | Instance UUID                        | Power State | Provisioning State | Maintenance |
+--------------------------------------+----------------------+--------------------------------------+-------------+--------------------+-------------+
| 5614c63b-4399-4e26-bb5e-be7e4b5f53d1 | openshift-master-0-1 | dd5a95e3-61ee-4dd2-bc10-a964b81eb6c1 | power on    | active             | False       |
| 96f42eb1-ceab-4acf-9a68-11d5cb33665c | openshift-master-0-2 | 633e9f37-9e62-4a35-b880-9fc9edf35863 | power on    | active             | False       |
| a5ed1e96-c6cf-4b81-9747-a5a8cc972c86 | openshift-master-0-0 | 99304380-b19a-47df-a4df-74cef9a9994f | power on    | active             | False       |
| bc8ed600-adfa-4343-baef-36b584fe69d6 | openshift-worker-0-0 | dbbdb049-bd35-49c2-a81d-cafc21348446 | power on    | active             | False       |
| 6a3bb3aa-cae0-475a-a92f-f1b251cc89ae | openshift-worker-0-1 | 2524ff52-e4aa-4daf-88ee-fe644a40699b | power on    | active             | False

Comment 5 errata-xmlrpc 2020-07-13 17:43:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.