Bug 1835460 - When user names contain a '#' in their name, the console cannot display the user resource
Summary: When user names contain a '#' in their name, the console cannot display the u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1840812
TreeView+ depends on / blocked
 
Reported: 2020-05-13 20:07 UTC by Cesar Wong
Modified: 2020-07-13 17:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the web console would not let you view user details when the username contained special characters such as '#'. The console now lets you see the user details regardless of special characters in the name.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
result of navigating to a user with # (77.84 KB, image/png)
2020-05-13 20:07 UTC, Cesar Wong
no flags Details
Verification screenshot (142.09 KB, image/png)
2020-05-28 01:51 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5566 None closed Bug 1835460: Handle resource names with special characters 2020-08-06 19:52:35 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:38:52 UTC

Description Cesar Wong 2020-05-13 20:07:30 UTC
Created attachment 1688199 [details]
result of navigating to a user with #

Description of problem:
In IBM public cloud, user names are of the format: name#domain
When trying to display a user through the console, you get a (404) Not Found error.

Version-Release number of selected component (if applicable):
3.4.18

How reproducible:
Always

Steps to Reproduce:
1. Create a username that contains '#'
2. Navigate in the console to the user

Actual results:
You get a 404 not found

Expected results:
The user information is displayed

Comment 3 XiaochuanWang 2020-05-28 01:51:24 UTC
Created attachment 1692906 [details]
Verification screenshot

Comment 4 XiaochuanWang 2020-05-28 01:52:15 UTC
Attached the screenshot for refer.
This is fixed on 4.5.0-0.nightly-2020-05-27-202943, it could be Verified.

Comment 5 errata-xmlrpc 2020-07-13 17:38:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.