Bug 1840812 - When user names contain a '#' in their name, the console cannot display the user resource
Summary: When user names contain a '#' in their name, the console cannot display the u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1835460
Blocks: 1851485
TreeView+ depends on / blocked
 
Reported: 2020-05-27 16:26 UTC by OpenShift BugZilla Robot
Modified: 2020-06-26 17:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the web console would not let you view user details when the username contained special characters such as '#'. The console now lets you see the user details regardless of special characters in the name.
Clone Of:
Environment:
Last Closed: 2020-06-23 00:57:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5605 None closed [release-4.4] Bug 1840812: Handle resource names with special characters 2020-08-06 19:53:03 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:45 UTC

Description OpenShift BugZilla Robot 2020-05-27 16:26:33 UTC
+++ This bug was initially created as a clone of Bug #1835460 +++

Created attachment 1688199 [details]
result of navigating to a user with #

Description of problem:
In IBM public cloud, user names are of the format: name#domain
When trying to display a user through the console, you get a (404) Not Found error.

Version-Release number of selected component (if applicable):
3.4.18

How reproducible:
Always

Steps to Reproduce:
1. Create a username that contains '#'
2. Navigate in the console to the user

Actual results:
You get a 404 not found

Expected results:
The user information is displayed

Comment 1 Samuel Padgett 2020-05-28 13:56:19 UTC
status: PR ready, waiting for cherry-pick-approved label

Comment 4 Yanping Zhang 2020-06-11 14:46:59 UTC
Checked on ocp 4.4 cluster with payload 4.4.0-0.nightly-2020-06-11-064343
Create a user "user#test1", and the user has ever login via client.
On console, go to the user's detail page, the page displays well.
The bug is fixed.

Comment 6 errata-xmlrpc 2020-06-23 00:57:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.