Bug 1835548 - Viewing the Developer Catalog in the Developer console shows no results until clicking Clear All Filters
Summary: Viewing the Developer Catalog in the Developer console shows no results until...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-14 02:57 UTC by Joel Pearson
Modified: 2020-07-13 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Persisted catalog filters took precedence over filters supplied in the URL. Furthermore clearing the applied filters did not persist. Consequence: When navigating to a specific catalog URL with filters in the URL, the catalog did not apply the URL filters and instead applied the filters from the previous visit. Even if the user cleared these filters, upon return the previous set was once again used. Fix: -Ignore saved filters from preferences if category filter is there in URL. -If user clears all filter, all the cleared filters are saved into localStorage rather than deleting the filter key like earlier. Result: Catalog URLs with filters work as expected and the user can now clear their filters and the result will persist.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5480 None closed Bug 1835548: Ignore saved filters if category in URL and save cleared filters 2020-06-30 18:35:08 UTC
Red Hat Bugzilla 1797891 None None None 2020-05-14 04:03:04 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:38:52 UTC

Description Joel Pearson 2020-05-14 02:57:32 UTC
Description of problem:
Viewing the Developer Catalog in the Developer console shows no results until clicking "Clear All Filters"

This applies to all categories.

This worked in 4.3.x, and there is no network traffic when I click "Clear All Filters", so I think it's a UI bug.

Version-Release number of selected component (if applicable): 4.4.3


How reproducible: Every time


Steps to Reproduce:
1. Navigate to the catalog eg: https://console-openshift-console.apps.cluster.domain.tld/catalog/ns/mysql-test?category=all
2. Shows a "No Results Match the Filter Criteria" message
3. Click "Clear All Filters"
4. All catalog items are now displayed

Actual results:

No Catalog items

Expected results:

Catalog items without having to click clear.

Additional info:

Comment 1 Joel Pearson 2020-05-14 03:44:49 UTC
Oh this might be https://bugzilla.redhat.com/show_bug.cgi?id=1810481

I've noticed that it's the "Type" (eg Operator Backed, Helm Charts, Builder Image, Template, Service Class) that is causing the filtering problems.

Mine had defaulted to "Operator Backed" which had no results, even when I clicked clear, reloading the page would put it back to "Operator Backed".

Now that I have selected a "Type" it seems to remember, including if I uncheck all the types, it now remembers that. But clicking "Clear All Filters" wouldn't persist that change.

It seems that for new sessions it defaults back to "Operator Backed", I think it should default to nothing checked.

Comment 2 Joel Pearson 2020-05-14 04:02:20 UTC
Ok, it looks like the actual bugzilla is https://bugzilla.redhat.com/show_bug.cgi?id=1797891.


This comment: https://bugzilla.redhat.com/show_bug.cgi?id=1797891#c4

says it was intentional, which I find really strange. Because when you go Add -> Database, it ends up showing nothing, which for me made me think my upgrade had failed and that all the templates were missing or something like that.

There is some smaller text that says "No developer catalog items are being shown due to the filters being applied.", which I thought it meant that there were no databases, because in my mind the database category is a type of filter.  There is nothing indicating in the UI about what is and what isn't a filter, there is only the search box which has "Filter by keyword..." in it, which is blank by default.

What is the reasoning by choosing "Operator Backed" by default?  If you have an existing namespace with some operators installed then you do get some results, but for new namespaces with no operators then you see nothing at all.  Or is this RedHat's way of signalling that Helm Charts, Builder Images, Templates and Service Classes are being deprecated?

Comment 3 cvogt 2020-05-14 17:38:11 UTC
Thank you Joel for your comments.

Clearing the filters should be persisted (this is a bug). Upon refresh, the filters should remain cleared.

When you go to Add -> Database the first time, it should not automatically select operator backed (another bug). Nor should it apply the previously saved filters. For this reason I'm increasing the severity as it creates a bad first experience.

Pre-selecting operator backed was a UX decision to promote their use.

Comment 7 Gajanan More 2020-05-28 12:04:38 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-05-28-044428
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 8 errata-xmlrpc 2020-07-13 17:38:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.