Bug 183557 - Current zsh in Fedora doesn't have Unicode support
Current zsh in Fedora doesn't have Unicode support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
: 205284 (view as bug list)
Depends On:
Blocks: FC7UpdateRequests
  Show dependency treegraph
 
Reported: 2006-03-01 17:15 EST by Frank Schmitt
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 18:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Schmitt 2006-03-01 17:15:27 EST
Description of problem: zsh 4.2.x's line editor doesn't support Unicode. You can
see this if you type something like üüüüüü on the shell prompt and then erase it
with Backspace. You delete more charcters than you want, that means you erase
your prompt.

zsh 4.3 is about to be released and already very stable. It would be great if we
could have this in Fedora ASAP as Fedoras default locale is UTF-8 and zsh 4.2.x
is quite broken for this locale as described above.

Version-Release number of selected component (if applicable):
4.2.x
Comment 1 Frank Schmitt 2006-03-02 06:16:17 EST
In fact 4.3.1 is already released (but not officially announced):

-------------------------------------------------------------------
From: Peter Stephenson <pws <at> csr.com>
Subject: 4.3.1 released
Date: 2006-02-28 13:06:30 GMT

I've uploaded

ftp://ftp.zsh.org/pub/zsh-4.3.1.tar.gz
ftp://ftp.zsh.org/pub/zsh-4.3.1.tar.bz2
ftp://ftp.zsh.org/pub/zsh-4.3.1-doc.tar.gz
ftp://ftp.zsh.org/pub/zsh-4.3.1-doc.tar.bz2

Please try this out on as many systems as possible as soon as you get a
chance; if there are any significant problems I'll produce a 4.3.2.
This is very little changed from 4.3.0-dev-5, so there shouldn't be any.
If it looks OK I'll make the appropriate arrangements at Sourceforge and
Freshmeat (please feel free to pass the message on elsewhere; I don't
use comp.unix.shell or Slashdot myself).

Thank you to everyone who helped.

The release announcement currently looks like:

This version contains initial support for multibyte characters in the
shell's line editor (in particular UTF-8, although any character set
supported by the system library is usable).  Please read the appropriate
sections of the file INSTALL as this support is not turned on by default
on all systems where it can be used.  The release also contains a few
enhancements to shell syntax and supplied functions as well as numerous
bug fixes.  See the file NEWS for more detail.  There are only a few
unavoidable incompatibilities with previous versions, mostly to enhance
compatibility with other shells and standards; see the README file.
-------------------------------------------------------------------
Comment 2 Christopher Aillon 2006-09-11 18:16:50 EDT
*** Bug 205284 has been marked as a duplicate of this bug. ***
Comment 3 Frank Schmitt 2006-12-27 17:43:41 EST
Even Suse and Debian (both really not known to ship unstable code) are shipping
zsh 4.3. (Suse already shipped in 10.2, Debian is going to ship in Edgy.) Why on
earth can't Fedora users have this to. And is there anybody reading those
bugzilla entries? I mean the initial report was nine month ago and there wasn't
any response, this is rather discouraging.
Comment 4 Daniel Qarras 2006-12-28 15:55:14 EST
I've been reading Zsh mailing lists and next zsh-4.3 release is probably going
to happen early next year, perhaps best is to wait for it or use latest code
from CVS, old 4.3 releases are far from perfect. However, I too strongly
recommended using 4.3 series, it contains Unicode support + lots of bug fixes
not in 4.2 branch.
Comment 5 Michel Alexandre Salim 2007-01-24 09:20:55 EST
Added to FC7 trackers
Comment 6 Matthias Clasen 2007-02-05 13:27:26 EST
zsh is not in the default install, so no way this is a blocker. 
Putting on FC7Target instead.
Comment 7 Christopher Aillon 2007-02-05 13:36:20 EST
Yeah, when a stable release is out with unicode support, I'll definitely add
that as I sorely need it (i currently switch to bash every now and then because
of this).  I wish that they'd have set a goal to only add unicode support and
nothing else, and simply work on that and get it solid quickly, but alas...
Comment 8 Matthias Clasen 2007-04-02 02:21:52 EDT
There is a zsh 4.3.2 release now, it seems, caillon.
Comment 9 Christopher Aillon 2007-04-02 11:22:54 EDT
4.3.x series is unstable.  They follow the GNOME and kernel numbering schemes of
Major.Even is stable, Major.Odd unstable.
Comment 10 Matthias Clasen 2007-04-02 12:14:03 EDT
oh, ok.
Comment 11 Matthias Clasen 2007-04-03 11:08:14 EDT
Moving off FC7Target then.
Comment 12 Caio Marcelo 2007-06-11 13:14:24 EDT
I've just sent an email about this bug to zsh developers mailing list. It may be
of your interest. (The latest release from zsh is 4.3.4)

http://www.zsh.org/mla/workers/2007/msg00469.html
Comment 13 Caio Marcelo 2007-06-11 19:15:33 EDT
Peter Stephenson (zsh maintainer) responded in the thread I've started

http://www.zsh.org/mla/workers/2007/msg00471.html

I think 4.3.4 is good enough for getting in Fedora. Even though is a "unstable"
version, for me getting Unicode right is reason enough (I'm using 4.3.4 from a
tarball).

What do the package maintainers (or others) think? I'm a fairly new user of zsh
so I don't have so much scripts that could break from incompatibilites, maybe
I'm overlooking this aspect of upgrading.
Comment 14 Mamoru TASAKA 2007-07-25 06:05:09 EDT
I know that Japanese users also complain about current
Fedora zsh as current zsh cannot Japanese character correctly
and wish to have zsh upgraded to >4.3 (on Japanese Fedora BBS).
Comment 15 Need Real Name 2007-07-25 12:13:49 EDT
Wasn't unicode support for all apps a requirement, back in early Fedora?
Comment 16 Ray Van Dolson 2007-07-25 14:31:23 EDT
How difficult would it be to backport unicode fixes into the current version?
Comment 17 Caio Marcelo 2007-07-27 10:29:24 EDT
After talking with some people in FreeNode zsh irc channel, backporting the
Unicode support to 4.2.x seems to be a bad idea. We would need someone
to do it (I don't think it's easy since is marked in the NEWS file of zsh
as a 'major change'), and would raise a lot of Fedora-specific bugs that
upstream won't support.

If no one have complaints about breaking old scripts compatibility, I think
we should follow upstream and go 4.3.4, which means: checking if the patches
we have for 4.2.x are still needed (if they are, try to push upstream the ones
we can) and updating the spec and do lots of other things that I don't know
about yet :-)

What do you think? Are the original package maintainers alive?
Comment 18 James Antill 2007-08-27 18:30:31 EDT
 Closing this as I just moved to the "unstable stable" version of zsh for Fed-8.
Comment 19 Frank Schmitt 2007-08-28 04:26:46 EDT
Thank you. I just rebuild under F7 and it seems to work nicely.

Note You need to log in before you can comment on or make changes to this bug.