Bug 183569 - adding layout to ABNT2 model crashes gnome-keyboard-properties
adding layout to ABNT2 model crashes gnome-keyboard-properties
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 183607 (view as bug list)
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-03-01 19:46 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 23:32:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 334084 None None None Never

  None (edit)
Description Alexandre Oliva 2006-03-01 19:46:13 EST
Description of problem:
If you open gnome-keyboard-properties, select Brazilian ABNT2 as the keyboard
model and then click to add a layout, g-k-p crashes.

Version-Release number of selected component (if applicable):
control-center-2.13.92-2
xorg-x11-xkbdata-1.0.1-6

How reproducible:
Every time

Steps to Reproduce:
1.Start gnome-keyboard-properties
2.Change the keyboard model to br-abnt2
3.Click on Add
  
Actual results:
It crashes

Expected results:
It shouldn't crash

Additional info:
Is it just me or today's rawhide has an older version of control-center?!?
Comment 1 Nicolas Mailhot 2006-03-02 10:45:37 EST
Same result when trying to configure a fr (alternate)/russian (winkeys) switcher
(it eventually works, but crashes a lot during setup) 

The difference with before the xkeyboard-config change is it crashed too, but
didin't eventually work
Comment 2 Ray Strode [halfline] 2006-03-02 15:21:28 EST
Hi guys,

I'm having difficulty reproducing the crashes you guys are experiencing.  Can
one of you provide a backtrace?  Do any messages get printed to the console
before the crash?

When it crashes does your theme change temporarily?
Comment 3 Nicolas Mailhot 2006-03-02 17:15:40 EST
My user font settings are different from system font settings (different dpi &
font sizes). When gconf is down I notice it at once because gnome fonts revert
to defaults (so a string of gconf crashes results in font flickering)

Today I can get the gnome applet to crash by selecting a microsoft natural
keyboard then trying to add a layout, but it's not bringing down gconf with it
like it did yesterday
Comment 4 Nicolas Mailhot 2006-03-02 17:24:02 EST
[nim@rousalka ~]$ gnome-keyboard-properties

** (gnome-keyboard-properties:31206): WARNING **: key AE00: keycode =
4294967295; not in range 8..255


-> crash
Comment 5 Ray Strode [halfline] 2006-03-02 17:25:51 EST
probably not bringing down gconf, but instead it probably is bringing down
gnome-settings-daemon

I see that warning, too, but no crash.  I can try to fix the warning and see if
it helps your problem.
Comment 6 Alexandre Oliva 2006-03-03 05:04:28 EST
I suspect you might need some earlier gnome-keyboard-properties configuration in
place to duplicate the crashes.  Big problem for OS upgrades, or even for
sharing a home dir across multiple OS versions :-(

Anyhow, here's a more detailed recipe do duplicate the problem.  I'll describe
as many steps as I can think of; not necessarily all of them are relevant:

1) use system-config-keyboard to configure your keyboard as br-abnt2 (its layout
is very similar to that of us, except for brackets, slashes and accents, so you
won't want to use this regularly on a us keyboard :-)
2) restart X
3) log into a gnome session
4) start gnome-keyboard properties
5) click on the layout tab
6) click on reset to defaults (you should now have a `Brazil' entry in selected
layouts)
7) click on ... next to keyboard model
8) select generic 101-key pc
9) click on add
10) select US English International (with dead keys)
11) click on add again
12) select US English Alternative international (former us-intl)
13) click on ... next to keyboard model
14) select Brazilian ABNT-2
15) click on add
crash

here's a partial backtrace I got:

(gdb) where
#0  0x0000000000415910 in gconf_property_editor_marshal_VOID__STRING_POINTER ()
#1  0x00000036d0c24ccd in g_list_foreach () from /usr/lib64/libglib-2.0.so.0
#2  0x0000000000416682 in gconf_property_editor_marshal_VOID__STRING_POINTER ()
#3  0x0000003c55d23c3d in gtk_marshal_BOOLEAN__VOID ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#4  0x00000036d0e0b21d in g_closure_invoke ()
   from /usr/lib64/libgobject-2.0.so.0
#5  0x00000036d0e1af28 in g_signal_override_class_closure ()
   from /usr/lib64/libgobject-2.0.so.0
#6  0x00000036d0e1c13d in g_signal_emit_valist ()
   from /usr/lib64/libgobject-2.0.so.0
#7  0x00000036d0e1c553 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#8  0x0000003c55dfd49e in gtk_widget_get_default_style ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#9  0x0000003c55d1e9f2 in gtk_main_do_event ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#10 0x0000003c5613257a in gdk_window_is_viewable ()
   from /usr/lib64/libgdk-x11-2.0.so.0
#11 0x0000003c5613270b in gdk_window_process_all_updates ()
   from /usr/lib64/libgdk-x11-2.0.so.0
#12 0x0000003c55c9d9e5 in gtk_container_check_resize ()
   from /usr/lib64/libgtk-x11-2.0.so.0
[...]

Oddly, if I also add `US English' after the 3 layouts above, the `Add' button is
disabled until I remove one any of the 4 layouts.  Feature or bug?
Comment 7 Ray Strode [halfline] 2006-03-09 15:55:08 EST
I commited a workaround in the code to prevent settings daemon from crashing. 
The root problem isn't yet fixed, however. 
Comment 8 Ray Strode [halfline] 2006-03-15 15:20:43 EST
*** Bug 183607 has been marked as a duplicate of this bug. ***
Comment 9 Joachim Frieben 2006-03-22 17:00:47 EST
Upgrading to libxklavier-2.2-1 according to Comment #5 of Bug #183607
has no impact on the issue (FC5 w/updates).
Comment 10 Ray Strode [halfline] 2006-03-22 17:09:51 EST
upstream bug report: http://bugzilla.gnome.org/show_bug.cgi?id=334084
novell bug report: https://bugzilla.novell.com/show_bug.cgi?id=158177
Comment 11 Ray Strode [halfline] 2006-03-29 11:25:11 EST
Novell reports a patch pulled from CVS:

https://bugzilla.novell.com/attachment.cgi?id=75018&action=view

fixes this problem.

Reassigning to xorg-x11-xkbdata (xkeyboard-config actually)
Comment 12 Ray Strode [halfline] 2006-03-29 12:14:08 EST
Hi,

So I played with the patch today.  I think it does fix the crashing problem, but
there are other issues with NumLock getting stuck on.  We should fix that issue,
too, before we push any updates.
Comment 13 Mike A. Harris 2006-07-27 15:38:57 EDT
Please report a detailed bug in freedesktop bugzilla against the
xkeyboard-config component at http://bugs.freedesktop.org so upstream
is aware of the issue.  Sergey is generally quite responsive.

Paste the URL here once it's been filed and we will track it.

Thanks in advance.
Comment 14 Alexandre Oliva 2006-07-31 23:32:11 EDT
The gnome-keyboard-properties bug I'd filed is fixed as far as I'm concerned.  I
don't even know why this is now against xkeyboard-config.

Note You need to log in before you can comment on or make changes to this bug.