Bug 183607 - gnome-keyboard-properties resets GTK theme to Clearlooks
gnome-keyboard-properties resets GTK theme to Clearlooks
Status: CLOSED DUPLICATE of bug 183569
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 04:52 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 15:20:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-03-02 04:52:30 EST
Description of problem:
Manipulating the keyboard layout settings resets the "GTK" theme to
"Clearlooks" when it used to be "Bluecurve"! 

Version-Release number of selected component (if applicable):
control-center-2.13.92-2

How reproducible:
always

Steps to Reproduce:
1. Execute "gnome-keyboard-properties".
2. Play around with the layout scheme settings.
  
Actual results:
"GTK" theme gets reset to "Clearlooks".

Expected results:
"GTK" theme shouldn't have been altered.

Additional info:
none
Comment 1 Matthias Clasen 2006-03-02 08:59:26 EST
hmm, doesn't happen here. Can you describe your "playing around" in more detail ?
What version of xorg-x11-xkbdata do you have ?
Comment 2 Ray Strode [halfline] 2006-03-02 10:36:58 EST
I wonder if settings daemon is crashing...
Comment 3 Joachim Frieben 2006-03-02 14:31:13 EST
To reverify the issue once again, I execute the following steps using
the mouse solely, not the keyboard:

1. Remove all dot directories (.gnome2, ..) in my account to reset them
   to factory defaults.
2. Upon log-in, set "GTK" theme to "Bluecurve". Works.
3. Launch "gnome-keyboard-properties".
4. Go to "Layouts" (Keyboard model: "Generic 105-key (Intl) PC",
   Scheme: "German Eliminate dead keys").
5. Click "Add..."
6. Select "U.S. English layout".
7. Confirm ("OK").

Bingo! The theme switches instantaneously to "Clearlooks". Reopen
"gnome-theme-manager", and see the theme switch back to "Bluecurve"
wich is still selected there. Version of "xorg-x11-xkbdata" is 1.0.1-6
which is the latest one. Without yesterday's "xorg-x11-xkbdata" mess,
I would have probably never noticed this one!
Comment 4 Joachim Frieben 2006-03-15 06:45:27 EST
Bug still present in "control-center-2.14.0-1". I checked with the
live CD of another distro that the issue is not Fedora specific.
It occurs there, too.
Comment 5 Ray Strode [halfline] 2006-03-15 12:16:37 EST
Hi Joachim, 

what if you upgrade to the libxklavier in rawhide?
Comment 6 Joachim Frieben 2006-03-15 14:38:07 EST
I installed the system from scratch yesterday (rawhide 03/14/06).
Todays updates were obviously also installed, thus including
"control-center-2.14.0-1" as stated in commet #4. Anything else
to update to?
Comment 7 Ray Strode [halfline] 2006-03-15 15:20:30 EST
No that should have everything (assuming you have libxklavier-2.1.0.2006.02.23-2).

I'm fairly sure this is a duplicate of bug 183569, but it could be the
workaround added to libxklavier to help address that bug doesn't actually work
around all the problem cases.

*** This bug has been marked as a duplicate of 183569 ***

Note You need to log in before you can comment on or make changes to this bug.