Bug 183572 - Installer does not give you chance to skip packages that could not be installed
Installer does not give you chance to skip packages that could not be installed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 183573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 20:16 EST by Mark Allyn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 20:29:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Allyn 2006-03-01 20:16:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I had a package fail to install because of a possible corruption on the CD. The package was something that I decided was not important and I wanted the installation to continue anyways.

The installer did not seem to offer a choice to 'skip and continue'. The only choice was to retry. When I did that, then the only choice was to reboot.

Can you please add a choice to 'ignore and skip' or 'skip and continue' when a package fails to install due to CD corruption?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install from CD (CD would have to have corrupted package)
2.Try to 'ignore and skip' package installation error
3.
  

Actual Results:  System re-booted; all work on install was lost

Expected Results:  Allowed to ignore the install error and continue on with the next package

Additional info:
Comment 1 Frank Arnold 2006-03-02 02:14:14 EST
*** Bug 183573 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-03-02 20:29:55 EST
Skipping packages is highly likely to lead to a broken system in cases where the
package is a requirement of other packages or especially if it's a base package.
Comment 3 Philippe Rigault 2006-03-05 08:59:43 EST
The user already can change to another CD/DVD before hitting 'retry', to try   
another (hopefully uncorrupted) media. 
 
However, since problems with corrupted media (expecially when created on 
Linux) and truncated installs are a _frequent_ event (from my experience), I 
think extra attention could be given to problems like this so that the 
installer deals with problems as gracefully as possible. 
 
> Skipping packages is highly likely to lead to a broken system  
Agreed, but how much more broken is a system where the installer has   
already formatted partitions, installed some packages, and stopped abruptly ?  
  
Certainly, if the package is not a requirement to others, then there is no  
problem skipping it and installing it later.  
  
A possible improvement might be to add an extra step after the user has  
selected packages, and before the formatting phase starts:  
 - Verify that selected packages can be read from the media(s) (y/n)?  
 
I bet more users would want to verify this step rather than do the whole media 
verification step at the beginning. Plus, it should be faster since less 
packages have to be verified. 
 
Not a perfect solution, but an improvement IMO. 
 
Cheers. 
 
   
   

Note You need to log in before you can comment on or make changes to this bug.