Bug 1835795 - [ovirt] allow template parameters customization (mem/cpu/disk) in the machine
Summary: [ovirt] allow template parameters customization (mem/cpu/disk) in the machine
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.4.z
Assignee: Roy Golan
QA Contact: Guilherme Santos
URL:
Whiteboard:
: 1823808 OCPRHV-61-4.4.z (view as bug list)
Depends On: 1820300 1835576
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-14 13:55 UTC by Roy Golan
Modified: 2020-06-16 09:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: No option to customize the worker/masters machine specifications Consequence: Users had to customize the RHV/oVirt template prior to installation, and point the installer to that template using an environment variable Fix: Allow customization of workers/masters by implementing MachinePool for this platform, and exposing it in the install-config.yaml Result: masters/workers VM instances are created according to the MachinePool details, including cpu/mem/disk/vmType/instanceType. As a result of now knowing how to handle a different disk size, the default disk size now is 120GB.
Clone Of: 1820300
Environment:
Last Closed: 2020-06-02 11:18:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-ovirt pull 48 0 None closed Bug 1835576: Downport instance customizaton based machine-pool 2020-10-31 19:48:14 UTC
Github openshift installer pull 3628 0 None closed Bug 1835795: downport disk extension support for masters/workers 2020-10-31 19:48:02 UTC
Red Hat Product Errata RHBA-2020:2310 0 None None None 2020-06-02 11:19:09 UTC

Comment 1 Jan Zmeskal 2020-05-19 11:34:13 UTC
*** Bug 1823809 has been marked as a duplicate of this bug. ***

Comment 5 Guilherme Santos 2020-05-26 08:31:46 UTC
Verified on:
openshift-install-linux-4.4.0-0.nightly-2020-05-24-133612

Steps:
1. created a config file: # openshift-install create --dir install_files/ install_config
2. edited the install-config.yaml setting the following variables with non-default value (XX)
(...)
controlPlane/compute:
  name: master/worker
  platform:
    ovirt:
      cpu:
        cores: XX
        sockets: XX
      memoryMB: XX
      osDisk:
        sizeGB: XX
      vmType: high_performance
(...)
platform:
  ovirt:
    api_vip: <ip>
    dns_vip: <ip>
    ingress_vip: <ip>
    ovirt_cluster_id: <id>
    ovirt_storage_domain_id: <id>
    ovirt_network_name: ovirtmgmt
    vnicProfileID: <id>
(...)

3. # openshift-install create --dir install_files/ cluster
4. on UI, checked the created machines properties

Results:
installation successfully finished and non-default properties set on yaml file present on vms

Comment 6 Roy Golan 2020-05-26 09:37:29 UTC
*** Bug 1823808 has been marked as a duplicate of this bug. ***

Comment 8 Guilherme Santos 2020-06-01 09:34:36 UTC
Talked to rdlugyhe and we agreed on the removing of "Create VM Template" procedure for 4.4.6.

Comment 9 errata-xmlrpc 2020-06-02 11:18:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310

Comment 10 daniel 2020-06-08 06:15:07 UTC
(In reply to Guilherme Santos from comment #8)
> Talked to rdlugyhe and we agreed on the removing of "Create VM Template"
> procedure for 4.4.6.

Do we then plan instead to document customizing install-config.yaml. 
Please forgive my ignorance, but I couldn't find and bz reflecting to get this into the docs and I would highly appreciate any hint to it.

Comment 11 Roy Golan 2020-06-09 10:35:10 UTC
(In reply to daniel from comment #10)
> (In reply to Guilherme Santos from comment #8)
> > Talked to rdlugyhe and we agreed on the removing of "Create VM Template"
> > procedure for 4.4.6.
> 
> Do we then plan instead to document customizing install-config.yaml. 
> Please forgive my ignorance, but I couldn't find and bz reflecting to get
> this into the docs and I would highly appreciate any hint to it.

Yes that will be documented properly.

Meanwhile you can use the repo document https://github.com/openshift/installer/blob/5d0b06afb924d7c69c44006c3d299cde8e93a6ad/docs/user/ovirt/customization.md


Note You need to log in before you can comment on or make changes to this bug.