Bug 18359 - Bug on kernel compilation
Bug on kernel compilation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
: 18913 19168 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 16:16 EDT by Dromaeosaurio
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 05:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dromaeosaurio 2000-10-04 16:16:06 EDT
hi

The RedHat Linux 7.0 CD (1 of 2) come with source of kernel version
2.2.16-22. But the kernel-headers version is the 2.4.

Well, with these source and headers i did try to recomplile a own kernel
but when i execute "make bzImage" the compilation process crash.

Then, i did install the kernel source & headers version 2.4. But the
results are the same:


-------------------------------------------------------------------

/usr/src/linux-2.4/include/linux/modules/ksyms.ver:1716:24: warning:
"del_timer_sync" redefined
/usr/src/linux-2.4/include/linux/timer.h:34:1: warning: this is the
location of the previous definition
In file included from ksyms.c:18:
/usr/src/linux-2.4/include/linux/kernel_stat.h: In function `kstat_irqs':
/usr/src/linux-2.4/include/linux/kernel_stat.h:98: `smp_num_cpus'
undeclared (first use in this
function)/usr/src/linux-2.4/include/linux/kernel_stat.h:98: (Each
undeclared identifier is reported only once
/usr/src/linux-2.4/include/linux/kernel_stat.h:98: for each function it
appears in.)
In file included from /usr/src/linux-2.4/include/linux/interrupt.h:45,
                 from ksyms.c:21:
/usr/src/linux-2.4/include/asm/hardirq.h:37:24: warning: "synchronize_irq"
redefined
/usr/src/linux-2.4/include/linux/modules/i386_ksyms.ver:138:1: warning:
this is the location of the previous definition
make[2]: *** [ksyms.o] Error 1
make[2]: Saliendo directorio `/usr/src/linux-2.4.0/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Saliendo directorio `/usr/src/linux-2.4.0/kernel'
make: *** [_dir_kernel] Error 2
----------------------------------------------------------------------

I thing these problem need a patch, really quickly.


Well, out of these problem, RedHat 7.0 is a great product. Congratulations.


Andris Reyes Douglas
Santiago
Chile

(sorry if my english is not very well at all)
Comment 1 Daniel Roesen 2000-10-04 18:29:45 EDT
Did you use kgcc to compile the kernel? Just a wild guess...
Comment 2 Harvey Modlin 2000-10-04 22:05:52 EDT
I get exact same error. I did full installation (everything) of RH7.0 to brand 
new hard drive. System is Pentium III 866mhz, 256mb RAM, Intel motherboard, 815 
chipset. No patches to kernel applied (YET!). Tried to recompile vanilla kernel 
and got same error messages. As a result no bzImage was created. Steps taken: 

cd /usr/src/linux
make menuconfig
## accept current configured, no changes, exit (to make .config)
make dep
make clean
make bzImage
## for future use...
## if this works, I will apply VPN masq patch, recompile,
## and continue with...
#make modules
#make modules_install
#cd /usr/src/linux/arch/i386/boot
## copy new bzImage to /boot, add reference for lilo, etc etc etc

And I agree with the comment "I thing these problem need a patch, really 
quickly."

from: modlin@mail.com
Comment 3 Arjan van de Ven 2000-10-05 03:05:30 EDT
This sounds like you didn't do a "make mrproper" between switching from
a SMP kernel to a non-SMP kernel. This is a known and tricky to fix bug in the
2.2 kernels, not just the Red Hat ones. You might not know you compiled a SMP
kernel before, but building from the src.rpm does that as well.
Comment 4 Harvey Modlin 2000-10-05 04:10:27 EDT
Not it, sorry. Here is part of my .config:
--------
# CONFIG_M386 is not set
# CONFIG_M486 is not set
# CONFIG_M586 is not set
# CONFIG_M586TSC is not set
CONFIG_M686=y
CONFIG_X86_WP_WORKS_OK=y
CONFIG_X86_INVLPG=y
CONFIG_X86_BSWAP=y
CONFIG_X86_POPAD_OK=y
CONFIG_X86_TSC=y
CONFIG_X86_GOOD_APIC=y
CONFIG_1GB=y
# CONFIG_2GB is not set
# CONFIG_MATH_EMULATION is not set
CONFIG_MTRR=y
# CONFIG_SMP is not set   <--- SEE, SMP IS NOT SET
#
# Loadable module support
#
CONFIG_MODULES=y
CONFIG_MODVERSIONS=y
-----------

Also, I have a "export CC=kgcc" before the makes.

So I am still mystified. I do appreciate any pointers you might be able to 
provide. I have saved all output from the makes, should this become necessary 
for debugging.
Comment 5 Harvey Modlin 2000-10-05 05:02:08 EDT
Aha. Found the problem! I really did forget to do the 'make mrproper' first! So 
with makr mrproper and 'export CC=kgcc', the kernel compiled just fine (thank 
you!) and the outcome was the bzImage file I wanted. Yippee! Thanks again.
Comment 6 Brad P. Crochet 2000-10-05 14:09:23 EDT
I still think this is a bug. The sources should be installed in a pristine
state, e.g. with a make mrproper already completed. This should be fixed.
Comment 7 Alan Cox 2000-10-14 13:48:48 EDT
*** Bug 18913 has been marked as a duplicate of this bug. ***
Comment 8 Alan Cox 2000-10-16 19:49:28 EDT
*** Bug 19168 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.