Bug 183627 - dos2unix doesn't preserve mode
dos2unix doesn't preserve mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: dos2unix (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On: 91331
Blocks: 143573
  Show dependency treegraph
 
Reported: 2006-03-02 07:12 EST by Tim Waugh
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2005-145
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 15:51:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-03-02 07:12:15 EST
+++ This bug was initially created as a clone of Bug #91331 +++

[hjl@gnu-d tmp]$ touch foo
[hjl@gnu-d tmp]$ chmod +x foo
[hjl@gnu-d tmp]$ ls -l foo
-rwxr-xr-x    1 hjl      hjl             0 May 21 08:14 foo
[hjl@gnu-d tmp]$ dos2unix foo
dos2unix: converting file foo to UNIX format ...
[hjl@gnu-d tmp]$ ls -l foo
-rw-------    1 hjl      hjl             0 May 21 08:14 foo

-- Additional comment from hjl@gnu.org on 2003-05-21 11:14 EST --
Created an attachment (id=91860)
A patch to preserve mode


-- Additional comment from mharris@redhat.com on 2003-05-21 11:29 EST --
*** Bug 55183 has been marked as a duplicate of this bug. ***

-- Additional comment from anders@kaseorg.com on 2003-11-05 23:03 EST --
I think it's worth pointing out that the user and group aren't
preserved either, though that's probably harder to fix.
Comment 5 Red Hat Bugzilla 2006-03-13 15:51:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-145.html

Note You need to log in before you can comment on or make changes to this bug.