Bug 183631 - pirut crashed when selecting optional packages
pirut crashed when selecting optional packages
Status: CLOSED DUPLICATE of bug 183310
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-03-02 08:13 EST by Andy Hudson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-02 14:40:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andy Hudson 2006-03-02 08:13:29 EST
Description of problem:
Trying to select packages under optional packages when pirut crashes

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Click package group
2.Click optional packages
3.Try to select a package to install
Actual results:
pirut crashes (traceback below)

Expected results:
Select optional package

Additional info:

Component: Software Manager
Summary: TB6d0a67a4 __init__.py:171:simpleDBInstalled:TypeError: unknown key type

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/GroupSelector.py", line 155, in
    elif self.ayum.simpleDBInstalled(name = pkg):
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 171, in
    mi = self.ts.ts.dbMatch('name', name)
TypeError: unknown key type

Local variables in innermost frame:
self: <__main__.PackageManager object at 0xb799fe2c>
name: xfce4-toys - 4.2.3-2.fc5.i386
Comment 1 Jeremy Katz 2006-03-02 14:40:48 EST

*** This bug has been marked as a duplicate of 183310 ***

Note You need to log in before you can comment on or make changes to this bug.