Bug 183685 - unable to update software using graphical tool
unable to update software using graphical tool
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
: 183957 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 14:59 EST by LarryT
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 18:59:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error during the running software updating (890 bytes, text/plain)
2006-03-02 14:59 EST, LarryT
no flags Details
running from shell (42.25 KB, image/jpeg)
2006-03-03 08:53 EST, LarryT
no flags Details

  None (edit)
Description LarryT 2006-03-02 14:59:28 EST
Description of problem:
Running software updater from /system tools /
error message during retrieving update infromation

Version-Release number of selected component (if applicable):


How reproducible:
running the software updater, i got an error. see attachement please

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 LarryT 2006-03-02 14:59:28 EST
Created attachment 125564 [details]
error during the running software updating
Comment 2 Jeremy Katz 2006-03-02 18:59:20 EST
You had another copy of pup/pirut/yum running.  I've changed things so the error
gets caught and gives a better error message now
Comment 3 LarryT 2006-03-03 00:30:16 EST
yep :-[ that's right i was running yum update when i launched the software updater !

Nevertheless i have just launched it now and i get only one message : 
unable to retrieve software information.
If i click 'ok' the window is closed.
yum works fine (since i have confgiure it with my proxy + user & passwd).
Comment 4 LarryT 2006-03-03 02:53:33 EST
i got the same message when i click on application/add remove software :
retrieving software information takes a long time and ends with the message
"unable to retrieve software information".

should i have some key to import ?
(i say again that yum works fine, since a configure the proxy using bashrc).
thx
Comment 5 LarryT 2006-03-03 08:53:06 EST
Created attachment 125594 [details]
running from shell
Comment 6 Jeremy Katz 2006-03-03 12:01:58 EST
If it's showing the dialog, then /var/run/yum.pid exists and has a valid pid of
a running process in it, which means that you can't run another copy of
yum/pup/pirut.  There's a case where it's not exiting properly right now and I'm
looking into that now
Comment 7 LarryT 2006-03-04 00:33:11 EST
well i am nearly sur that the problem is around the proxy.
To use yum i need to configure bashrc with http_proxy and a second line with
export http_proxy !
If i type those info in the yum.conf, it doesn't work and returns the message :
Cannot find a valid baseurl for repo: development
Error: Cannot find a valid baseurl for repo: development

This is exactly the same message i get with software updater !

Is there a way to configure proxy to work with software updater ?
Comment 8 Jeremy Katz 2006-03-04 11:16:10 EST
*** Bug 183957 has been marked as a duplicate of this bug. ***
Comment 9 David Lawrence 2006-06-27 21:34:33 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.