Bug 18374 - Upgrade from 6.2 (and 7.0beta) to 7.0 UNINSTALL my ssh w/o question or notice
Upgrade from 6.2 (and 7.0beta) to 7.0 UNINSTALL my ssh w/o question or notice
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 18649 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 23:11 EDT by Ale Feltes Quenhan
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-13 14:35:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ale Feltes Quenhan 2000-10-04 23:11:29 EDT
I did an upgrade from 6.2 to 7.0 on everal machines and my ssh-2.2.0 from
ssh.com was uninstalled.
I see that there was installed an openssh but it does not have the same
functionality of ssh.
First the installation replace my copy with one that does not fit my
requeriments.
And second that was even a Red Hat rpm, so why the unistallation????
It's really annoying because i use very much the ssh and I had to install
it again.
I had historically problems with Red Hat upgrades, especially with the
services, that very often get the config files overwritten or renamed, but
not erased, until now.
The same problem i get with one machine runnig the 7.0beta (6.9.5
pinstripe).
Comment 1 Nalin Dahyabhai 2000-10-05 15:37:57 EDT
The openssh package obsoletes the ssh package.  The other option is to have them
conflict, but they can't be installed simultaneously and still work, and there's
always the possibility that the upgrade will break ssh with newer versions of
shared libraries it depends on.
Comment 2 Ale Feltes Quenhan 2000-10-06 14:26:35 EDT
First, it can not obsoletes because is an alternative implementation of the ssh
and although it has most of the functions of the ssh, it does not have all of
the functions (i.e. some algorithms for encryption, SFTP).
Second there is no problem with libraries, i reinstalled the ssh and worked
fine, as they did before the upgrade.
Third, the upgrade only installed the package: openssh-2.1.1p4-1.i386.rpm
At least it could let you with a functional alternative implementation that
could have been done installing also the package corresponding to the server and
the client of the openssh.
An as a constructive critic i must add that there is no warranty that after an
upgrade of red hat Linux system, a running customized server of anything keep
doing his work, mostly because the configuration files i mentioned in the
original bug report.
I think you should pay more attention in this field. Red Hat comes with many
server applications running smoothly, but its too innocent to pretend that the
configuration files would remain untouched.
Comment 3 Nalin Dahyabhai 2000-10-06 15:08:54 EDT
If binaries on the system (/usr/sbin/sshd, for example) are present and listed
as being present in the RPM database, the installer automatically marks packages
on the CD which contain those files for installation during an upgrade.  This
allows for smooth upgrades when large packages (like XFree86) get split into
smaller, more modular subpackages (which allows installation of one X server
instead of all of them).  Without looking at the ssh package, I can't really
tell why it didn't work on your machine.
Please understand that binary compatibility of third-party applications is very
difficult to ensure in major releases.  That's why the version number jumps. 
I'm glad to see that the ssh package still works, though, but it's not something
I can honestly guarantee.
Missing algorithms are missing because of potential licensing and
patent-infringement issues which both we and you could run afoul of.  Leaving
them out was a conscious decision made by the openssh developers, and personally
I agree with that decision.  The Obsoletes tag is also present in the packages
from openssh.com, which is why we didn't take them out.
Short of customizing the list of packages to be upgraded and deselecting
openssh, I don't see a simple way to fix this problem.
Comment 4 Ale Feltes Quenhan 2000-10-07 00:52:57 EDT
Ok.
Thanks for the aclarations.
But still I think that if the installer found ssh it can add openssh{server,
client} to the instalation.
The ssh installs  most of its files in /usr/local and the openssh does not.
The reason I used ssh was because we had a license for windows and honestly I
did'n know very much about the openssh compatibility
I agree with you, about the license but still hold the critic to the installer.
I also understand the complications about the major distribution, but you have
to consider too, that previos Red Hat distribution did not contain openssh, I
need some secure access, that's what i installed ssh.
I have no problem on using openssh, is just that, after the update I could not
do it. I might have not notice the problem if the program ("upgraded") was
really a replacement.
My point is: Since Red Hat does not provide the solution to all the problems
and/or needs (something imposible to acomplish for any human, i understand
that); the instalation sould not touch third party programs or at least warn you
about that.

Comment 5 romano 2000-10-10 05:40:18 EDT
*** Bug 18649 has been marked as a duplicate of this bug. ***
Comment 6 Pekka Savola 2000-10-13 14:35:39 EDT
Almost automatic upgrade of ssh-1.2.xx or ssh-2.y.z from SSH inc. 
is considered a feature.


Note You need to log in before you can comment on or make changes to this bug.