Bug 18649 - ssh-add does not work for DSA keys
ssh-add does not work for DSA keys
Status: CLOSED DUPLICATE of bug 18374
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 14:14 EDT by romano
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 03:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description romano 2000-10-08 14:14:54 EDT
I generated a new key with keygen -d (openssh-2.1.1p4-1) and then my
ssh-agent does not 
accept that key with the following (strange) error: 

(0)hazel:~% ssh-add .ssh/id_dsa
Bad key file .ssh/id_dsa: Success
Comment 1 romano 2000-10-09 03:27:26 EDT
Additional note: I resolved the problem by upgrading to openssh-2.2.0p1. I
discovered that _before_
doing the upgrade to rh7 I had the 2.2.0 package installed and working;
strangely enough, the
upgrade process did downgrade my version of openssh.

My DSA connections are working ok with 2.2.0 (client and server).
Comment 2 romano 2000-10-10 05:40:24 EDT
OK. Solved with the update.

*** This bug has been marked as a duplicate of 18374 ***

Note You need to log in before you can comment on or make changes to this bug.