Bug 1838196 - stop printing usage help when the server commands [NEEDINFO]
Summary: stop printing usage help when the server commands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.z
Assignee: Michal Fojtik
QA Contact: Ke Wang
URL:
Whiteboard:
: 1838197 (view as bug list)
Depends On: 1838199
Blocks: 1838201
TreeView+ depends on / blocked
 
Reported: 2020-05-20 15:59 UTC by David Eads
Modified: 2020-07-14 16:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1838195
: 1838201 (view as bug list)
Environment:
Last Closed: 2020-07-14 16:11:52 UTC
Target Upstream Version:
sdodson: needinfo? (mfojtik)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25003 None closed [release-4.3] Bug 1838196: stop printing usage help when the server commands exit 2020-07-27 18:52:56 UTC
Red Hat Product Errata RHBA-2020:2872 None None None 2020-07-14 16:12:06 UTC

Comment 1 Lukasz Szaszkiewicz 2020-06-18 09:36:31 UTC
*** Bug 1838197 has been marked as a duplicate of this bug. ***

Comment 2 David Eads 2020-06-18 13:50:31 UTC
@mfojtik.  I can't figure out how to fix the paperwork, but you're looking for https://github.com/openshift/origin/pull/25003

Comment 4 W. Trevor King 2020-06-25 04:01:16 UTC
This 4.3 bug should only depend on the master-ward 4.4 bug 1838199.

Comment 8 Ke Wang 2020-07-06 06:48:40 UTC
Verified with OCP build 4.3.0-0.nightly-2020-07-04-055556,

- In one terminal, enter into master 
$ master=$(oc get nodes | grep master | head -1 | cut -d " " -f1)
$ oc debug node/$master
sh-4.2# chroot /host
Try incorrect parameter to endpoint,
sh-4.4#  curl -k --silent --show-error https://localhost:6443/readyz1

$ cd /var/log/pods

$ grep -nr 'Usage' openshift-*

No results found.

So the bug was fixed, move the bug verified.

Comment 10 errata-xmlrpc 2020-07-14 16:11:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2872


Note You need to log in before you can comment on or make changes to this bug.