Bug 1838810 - the read-only CR cannot be reconciled after removing the root cloud creds
Summary: the read-only CR cannot be reconciled after removing the root cloud creds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Joel Diaz
QA Contact: wang lin
URL:
Whiteboard:
Depends On: 1838718
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-21 20:26 UTC by OpenShift BugZilla Robot
Modified: 2020-06-17 22:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The cloud-credential-operator had special-case handling for the CCO's own read-only CredentialsRequest CR that required the existence of the cloud root creds. Consequence: If the cloud root creds are missing, CCO would be unable to reconcile CCO's own read-only CredentialsRequest CR. Fix: Use the read-only CredentialsRequest credentials to validate the read-only CredentialsRequest just like every other CredentialsRequest. Result: Removing the cloud root creds doesn't put CCO into a degraded state.
Clone Of:
Environment:
Last Closed: 2020-06-17 22:26:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 191 None closed [release-4.4] Bug 1838810: do not special-case handling read-only credentialsRequest 2020-06-28 03:31:22 UTC
Red Hat Product Errata RHBA-2020:2445 None None None 2020-06-17 22:26:53 UTC

Description OpenShift BugZilla Robot 2020-05-21 20:26:39 UTC
+++ This bug was initially created as a clone of Bug #1838718 +++

Description of problem:
After removing the root cloud credentials secret (eg kube-system/aws-creds), when the cloud-credential-operator goes to re-reconcile the read-only creds (cloud-credential-operator-iam-ro), it fails b/c it cannot find the root credentials (which of course were previously deleted).

Version-Release number of selected component (if applicable):

4.4.4


How reproducible: 100%


Steps to Reproduce:
1. Install OpenShift 4.4.4 on AWS
2. Delete the secret kube-system/aws-creds
3. Wait for CCO to reconcile the read-only CR

Actual results:

CCO will fail to reconcile the read-only credentials.


Expected results:

CCO doesn't enter an error state (where not all credentials have been successfully reconciled) when the root creds are removed.


Additional info:

Comment 2 Scott Dodson 2020-06-02 17:53:40 UTC
This was bumped to high because this is blocking a customer deployment.

Comment 5 wang lin 2020-06-08 09:41:17 UTC
The bug has been fixed.
The test payload is 4.4.0-0.nightly-2020-06-07-075345

The result is as below:
1.Install OpenShift on AWS
2.wait for cco reconcile (it is about 6 hours)
3.The cco successes to reconcile the read-only credentials and don't Degraded

$ oc get co cloud-credential
NAME               VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
cloud-credential   4.4.0-0.nightly-2020-06-07-075345   True        False         False      8h

Comment 7 errata-xmlrpc 2020-06-17 22:26:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445


Note You need to log in before you can comment on or make changes to this bug.