Bug 1839114 - Environment Variables can not be added to knative service through Add flow
Summary: Environment Variables can not be added to knative service through Add flow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1839115
TreeView+ depends on / blocked
 
Reported: 2020-05-22 14:07 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Unable to add environment variables for knative service Consequence: for the apps where envVariables would be need might not work as expected Fix: Added support for Environment variables in advance section Result: User can add environment variables for knative Service
Clone Of:
Environment:
Last Closed: 2020-07-13 17:41:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
on form (156.54 KB, image/png)
2020-05-26 10:07 UTC, Gajanan More
no flags Details
After creating kn service (181.56 KB, image/png)
2020-05-26 10:07 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:41:27 UTC

Description Jaivardhan Kumar 2020-05-22 14:07:58 UTC
Description of problem:
Environment Variables can not be added to knative service through Add flow

Version-Release number of selected component (if applicable):4.4


How reproducible: always


Steps to Reproduce:
1. Install Serverless operator
2. go to devConsole -> add -> git import
3. select knative service

Actual results: Can't add environment variables for knative 


Expected results: Should be able to add environment variables for knative 


Additional info:

Comment 3 Gajanan More 2020-05-26 10:07:22 UTC
Created attachment 1692195 [details]
on form

Comment 4 Gajanan More 2020-05-26 10:07:57 UTC
Created attachment 1692196 [details]
After creating kn service

Comment 5 Gajanan More 2020-05-26 10:08:20 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-05-25-232952
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared
Marking this as verified

Comment 6 errata-xmlrpc 2020-07-13 17:41:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.