Bug 1839115 - Environment Variables can not be added to knative service through Add flow
Summary: Environment Variables can not be added to knative service through Add flow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.z
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1839114
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-22 14:10 UTC by OpenShift BugZilla Robot
Modified: 2020-06-23 00:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Unable to add environment variables for knative service Consequence: for the apps where envVariables would be need might not work as expected Fix: Added support for Environment variables in advance section Result: User can add environment variables for knative Service
Clone Of:
Environment:
Last Closed: 2020-06-23 00:57:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5541 None closed [release-4.4] Bug 1839115: adds support for addition/updation of env variables and imagePullPolicy 2020-06-30 18:20:28 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:45 UTC

Description OpenShift BugZilla Robot 2020-05-22 14:10:00 UTC
+++ This bug was initially created as a clone of Bug #1839114 +++

Description of problem:
Environment Variables can not be added to knative service through Add flow

Version-Release number of selected component (if applicable):4.4


How reproducible: always


Steps to Reproduce:
1. Install Serverless operator
2. go to devConsole -> add -> git import
3. select knative service

Actual results: Can't add environment variables for knative 


Expected results: Should be able to add environment variables for knative 


Additional info:

Comment 3 Gajanan More 2020-06-15 10:48:59 UTC
I have verified it on:
Build: 4.4.0-0.ci-2020-06-15-004655
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 5 errata-xmlrpc 2020-06-23 00:57:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.