This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 183922 - Kernel/initrd boot hang on Tyan S2462 (Thunder K7)
Kernel/initrd boot hang on Tyan S2462 (Thunder K7)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Red Hat Kernel Hardware Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 14:23 EST by gary.anderson
Modified: 2012-06-20 09:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 2827 None None None Never

  None (edit)
Description gary.anderson 2006-03-03 14:23:12 EST
Description of problem:
Any RHEL4 2.6-based kernel will temporarilly hang with this sequence of messages:

Loading vmlinuz....
Loading initrd.gz......................
<screen clears, and hangs at blinking cursor for exactly 10 mins. (600 seconds)>
<boot continues normally after hang>

The messages above are from the RHEL4u2 CD#1 boot process.  This sequence
happens with any bootable media having any version of RHEL4 installed on it.


Version-Release number of selected component (if applicable):
RHEL4 i386 box distribution CD#1,
RHEL4u2 i386 CD#1,
RHEL4 i386 DVD install disc,
Any installed RHEL4 system with or without latest updates.


How reproducible:
Always, at boot time


Steps to Reproduce:
(RHEL4u2 i386 CD#1 used in example)
1. Insert install CD.
2. Boot machine to 'boot:' prompt.
3. Press enter to boot (or select any other option), machine hangs for 10 mins.
  

Actual results:
Machine hangs for 10 mins. (600 seconds) after loading the initrd.
The kernel continues booting normally after this pause.


Expected results:
Instant boot messages showing the kernel boot process.


Additional info:
This occurs on BIOS revisions 2.09, 2.11, and the latest, 2.14.
We currently have no way to test other BIOS revisions.
We have a lot of these machines with the Tyan S2462 to work with.  All the
machines exhibit this behaviour.
We have loaded RHEL3 in all stages up to RHEL3u6 and have not encoutered this
problem.  It seems this only shows in the 2.6.x kernel series.
We have tried the boot options "pci=noapic", "noapic", "noapm", "noacpi".
We have tried turning off/on ACPI in the BIOS.
We have tried changing the MP spec from 1.4 to 1.1.
We have tried setting "Use PCI Interrupt Entries in MP Table" to "yes".
We have tried clearing the BIOS, resetting ECSD, and changing the motherboard
battery.
Comment 1 gary.anderson 2006-03-07 17:06:45 EST
Did some research on this bug.  It seems that there is a resolution and problem
description over at the Kernel.org Bugzilla that matches this issue:

http://bugzilla.kernel.org/show_bug.cgi?id=2827
Bugzilla Bug 2827 boot delay before console displays

The basic description of the bug is that the kernel has CONFIG_VIDEO_SELECT
enabled ("Video mode selection support"), and reads the EDID from the Matrox
G450 card - but it hangs during the read due to an issue reading the Video BIOS
DDC from cards that "do" DDC1.

The main problem lies in the "call store_edid" function in
arch/i386/boot/video.S.  It is reccomended to comment out this fuction and
recompile.

I can confirm that the bug does not occur on a Tyan 2462 mainboard with a Siluro
FX 5200 (nVidia).  I suspect that it will not occur with other cards as well,
but I have to locate some other cards to test with first.
Comment 2 Jason Baron 2006-03-09 13:00:30 EST
great pointer! thanks for the help :) we'll get somebody to look into the
appropriate fix for rhel4. thanks.
Comment 4 gary.anderson 2006-04-12 14:02:18 EDT
Is there any more movement on this bug?  I have more than quite a few production
RHEL4 systems that match this profile to keep in line with any kernel updates
that might happen.  Recopiles are a pain for that many.
Comment 5 Jiri Pallich 2012-06-20 09:29:24 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.