Bug 183939 - messy desktop after log in
messy desktop after log in
Status: CLOSED DUPLICATE of bug 182495
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 17:03 EST by Leo
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-16 05:06:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a screenshot of my desktop (305.92 KB, image/png)
2006-03-03 17:03 EST, Leo
no flags Details

  None (edit)
Description Leo 2006-03-03 17:03:40 EST
Description of problem:
When user log in, the icons on the desktop is untidy even though it has been
cleaned up in the previous session.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Leo 2006-03-03 17:03:40 EST
Created attachment 125627 [details]
a screenshot of my desktop
Comment 2 Dennis Jacobfeuerborn 2006-03-05 18:12:29 EST
I'm seeing something like this too although on my desktop it's only the computer
and home direcory icons that appear in the wrong place.
They also appear always at the same place after login even after I fix their
position and reboot.
Comment 3 Alexander Larsson 2006-03-06 05:30:11 EST
There is a fix in gnome cvs that might be related to this:
2006-03-03  Alexander Larsson  <alexl@redhat.com>

	* libnautilus-private/nautilus-icon-canvas-item.[ch]:
	measure text in nautilus_icon_canvas_item_get_text_rectangle to avoid
	icons jumping around
	
I haven't verified atm.
Comment 4 Bart Vanbrabant 2006-03-15 06:50:22 EST
Isn't this the same bug as this one #182495
Comment 5 Alexander Larsson 2006-03-16 05:06:33 EST

*** This bug has been marked as a duplicate of 182495 ***
Comment 6 Stewart Adam 2006-03-16 18:15:08 EST
Yes, I've been posting to that one and it's the exact same behaviour -- no
matter how much I move or realign my icons they will arrange themselves in their
own little special way on re-login.
Firewing1
Comment 7 Dennis Jacobfeuerborn 2006-04-04 10:24:17 EDT
I'm still seeing this in current Rawhide. Where exactly is the icon position
stored on the gnome desktop? I'd like to find out if it's the icon position data
on disk that is the problem or the interpretation of that data.
Comment 8 Stewart Adam 2006-04-04 16:25:47 EDT
I believe in .gnome, .gnome2, .nautilus or .metacity... All hidden folders,
you'll need 
ls -Al
to see them.
Check in those, the positions are in XML files... I remember looking at them
myself at one time... (Those folders are hidden, that's why there's a "."
infront of them, and they're in the ~ directory)
Firewing1
Comment 9 Dennis Jacobfeuerborn 2006-04-05 10:40:16 EDT
The only file I found was in .nautilus and that one seemed to be stale (it was
from 2005 and the contents don't reflect my current desktop). I also checked the
gconf settings but I cannot find where the icon positions are hidden.
Comment 10 Stewart Adam 2006-04-05 19:50:34 EDT
I found mine (current ones, too!) in .nautilus/metafiles:

[user@DellLin metafiles]$ ls
computer:%2F%2F%2F.xml
file:%2F%2F%2Fboot%2Fdata%2Fuser%2FDesktop%2Fbg.xml
file:%2F%2F%2Fboot%2Fdata%2Fuser%2FDesktop%2FCustom%2520RPM%2520packages.xml
file:%2F%2F%2Fboot%2Fdata%2Fuser%2FDesktop%2FNext%2520CD.xml
file:%2F%2F%2Fboot%2Fdata%2Fuser%2FDesktop.xml
file:%2F%2F%2Fboot%2Fdata%2Fuser%2F.Trash.xml
file:%2F%2F%2Fboot%2Fdata.xml
file:%2F%2F%2Fmedia%2FUTILS%2Ffc5iso.xml
file:%2F%2F%2Fmedia.xml
file:%2F%2F%2Fvar%2Fwww%2Fhtml%2Fecohosting.xml
file:%2F%2F%2Fvar%2Fwww%2Fhtml%2Fphp-bin.xml
file:%2F%2F%2Fvar%2Fwww%2Fhtml.xml
trash:.xml
x-nautilus-desktop:%2F%2F%2F.xml


Firewing1

Note You need to log in before you can comment on or make changes to this bug.