Bug 183961 - freecell dies as soon as you try to start it
freecell dies as soon as you try to start it
Status: CLOSED DUPLICATE of bug 177886
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 22:06 EST by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 03:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-03-03 22:06:46 EST
Description of problem:
If I start freecell directly, the disk flickers, but no screen appears.
If I start the solatire app then try to pick freecell as the version
to play, the window immediatly blips out of existance

Version-Release number of selected component (if applicable):
gnome-games-2.13.8-1

How reproducible:
every time

Steps to Reproduce:
1. Run sol --variation freecell
  
Actual results:
sol --variation freecell
Backtrace:
In /usr/share/sol-games/freecell.scm:
 581: 0* (define kill-thread-mutex (make-mutex))
 581: 1* (make-mutex)

/usr/share/sol-games/freecell.scm:581:27: In expression (make-mutex):
/usr/share/sol-games/freecell.scm:581:27: Unbound variable: make-mutex

Expected results:
A freecell game to play :-).

Additional info:
Comment 1 Tom Horsley 2006-03-14 14:08:43 EST
Just as a point of reference, this appears to be a 64 bit bug of some kind.
The x86 version of FC5t3 gnome-games runs freecell just fine.
Comment 2 Ray Strode [halfline] 2006-03-14 19:28:23 EST
Hi,

There is a dupe for this somewhere I think, although I can't find it off hand.

It's a guile bug with 64-bit threading support.
Comment 3 Miroslav Lichvar 2006-03-15 03:08:50 EST

*** This bug has been marked as a duplicate of 177886 ***

Note You need to log in before you can comment on or make changes to this bug.