Bug 177886 - guile isn't built with thread support on x86-64
Summary: guile isn't built with thread support on x86-64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
: 179995 183961 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-16 06:03 UTC by Nathan G. Grennan
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 10:12:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2006-01-16 06:03:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Freecell doesn't start from the applications menu or a terminal window.

This is a x86_64 install.


[edgan@proton ~]$ sol --variation=freecell
Backtrace:
In /usr/share/sol-games/freecell.scm:
 581: 0* (define kill-thread-mutex (make-mutex))
 581: 1* (make-mutex)

/usr/share/sol-games/freecell.scm:581:27: In expression (make-mutex):
/usr/share/sol-games/freecell.scm:581:27: Unbound variable: make-mutex



Version-Release number of selected component (if applicable):
gnome-games-2.13.4-2

How reproducible:
Always

Steps to Reproduce:
1. yum install gnome-games
2. sol --variation=freecell
  

Actual Results:  Errors

Expected Results:  New window of freecell

Additional info:

Comment 1 David Timms 2006-02-05 03:06:02 UTC
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179995 is a duplicate of
this bug.
On a Pentium4 (HP compaq nx9000) i386, the shown error message for 2.13.6-3:

# sol --variation freecell
sol: error while loading shared libraries: libqthreads.so.12: cannot enable
executable stack as shared object requires: Permission denied

# sol
sol: error while loading shared libraries: libqthreads.so.12: cannot enable
executable stack as shared object requires: Permission denied

This suggests selinux policy; changing to permissive allowed both commands to
operate normally.

Comment 2 Matthias Clasen 2006-02-05 03:41:52 UTC
*** Bug 179995 has been marked as a duplicate of this bug. ***

Comment 3 Jim Cornette 2006-02-05 17:30:03 UTC
As confirmation:
I'm getting the program to launch fine with SELinux in permissive but not with
it in enforcing mode.

With SELinux enforcing:
sol --variation freecell
sol: error while loading shared libraries: libqthreads.so.12: cannot enable exec
utable stack as shared object requires: Permission denied

With 'selinux 0' issued first, this launches fine for me in the terminal or from
the menu. There are no errors outputted to the terminal.

Comment 4 Nathan G. Grennan 2006-02-06 16:40:24 UTC
I don't think this is the same bug. I always run with SELinux disabled. I
haven't retested this bug in a while. I will do so when I next get the chance.

Comment 5 Jim Cornette 2006-02-11 13:13:52 UTC
The SELinux problem seems to be resolved on an i386 system anyway. Your error
symptoms on an x86_64 with mutex are different than the bug experienced and
caused by SELinux policies.
You are right, same program errors out, but for different reasons and with
different symptoms.


Comment 6 Matthias Clasen 2006-02-21 21:03:44 UTC
Confirmed. I see the problem on x86_64, but not on i386

Comment 7 Miroslav Lichvar 2006-03-02 11:51:21 UTC
Guile-1.6.7 uses quickthreads implementation for threads. Unfortunately,
quickthreads support only few architectures, x86_64 isn't among them, the same
for PPC. However, the recently released guile-1.8.0 uses POSIX threads, so there
will be support for threads on all architectures.

In the meantime, would it be an option to downgrade the freecell.scm to one
without threads?

Comment 8 Ray Strode [halfline] 2006-03-02 15:40:31 UTC
Hi Miroslav,

If guile-1.8.0 is already released, can we just get it into rawhide? I can do it
if you like.

Comment 9 Miroslav Lichvar 2006-03-02 16:30:25 UTC
Hi Ray,

yes, I'm working on it, but there are some problems, for instance crashes on
x86-64. Of course, if you want help me I will appreciate that.

Comment 10 Miroslav Lichvar 2006-03-15 08:09:02 UTC
*** Bug 183961 has been marked as a duplicate of this bug. ***

Comment 11 Tom Horsley 2006-04-28 00:22:32 UTC
Well, the really important news is that with the gnome-games-2.14.1-1.fc5.3
that just arrived on my system in the latest update, freecell works
even on x86_64 system. Guile hasn't been updated, so I assume something
changed in the freecell implementation to work around the thread problem.


Comment 12 Miroslav Lichvar 2006-05-09 10:12:16 UTC
guile-1.8.0 is in rawhide.


Note You need to log in before you can comment on or make changes to this bug.