Bug 1839970 - New version of the plugin is available: 1.0.7
Summary: New version of the plugin is available: 1.0.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: RH Cloud - Inventory
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: 6.7.2
Assignee: Shimon Shtein
QA Contact: Mirek Długosz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-26 06:48 UTC by Shimon Shtein
Modified: 2020-07-30 20:21 UTC (History)
3 users (show)

Fixed In Version: tfm-rubygem-foreman_rh_cloud-1.0.7-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-30 20:21:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github theforeman foreman-packaging pull 5284 0 None closed Bump rubygem-foreman_rh_cloud to 1.0.7-1 2020-09-25 10:31:04 UTC
Red Hat Product Errata RHBA-2020:3255 0 None None None 2020-07-30 20:21:26 UTC

Description Shimon Shtein 2020-05-26 06:48:50 UTC
Features:

* Added cloud identification fields. Now we know to report on which cloud the host lives (based on https://mojo.redhat.com/docs/DOC-1138484)
* Added organizations filter in the UI. Now you can filter organizations that you see for uploads. The filter defaults to current organization.
* Added hostname obfuscation. Triggered by both a setting in Satellite and insights-client (if installed on a machine). Insights-client configuration reporting is tracked here: https://projects.engineering.redhat.com/browse/RHCLOUD-6003
* Added permissions and organization filtering. Now members of Org Admins, Managers and System Admins roles will be able to see and invoke uploads. Also added a new ForemanRhCloud role that can be used to grant upload permissions to any other users.

Upstream packaging: https://github.com/theforeman/foreman-packaging/pull/5284
Rubygems: https://rubygems.org/gems/foreman_rh_cloud/versions/1.0.7

Comment 1 Mirek Długosz 2020-07-10 15:14:36 UTC
All features introduced in this version are tested.
Swatch team confirmed that CRC side works with reports produced by Satellite.

Due to bug #1854824 , I needed to use workaround to install plugin (yum & satellite-maintain service restart instead of using satellite-installer).

Tested on:
Satellite 6.7.2 snap 1
foreman-1.24.1.24-1.el7sat.noarch
satellite-6.7.2-1.el7sat.noarch
pulp-server-2.21.0.1-1.el7sat.noarch
katello-3.14.0-6.el7sat.noarch
tfm-rubygem-foreman_rh_cloud-1.0.7-1.el7sat.noarch

Comment 4 errata-xmlrpc 2020-07-30 20:21:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3255


Note You need to log in before you can comment on or make changes to this bug.