Bug 1839977 - Installed operator lost link of Operator Group on detail page
Summary: Installed operator lost link of Operator Group on detail page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1840398 1840400
TreeView+ depends on / blocked
 
Reported: 2020-05-26 07:05 UTC by XiaochuanWang
Modified: 2020-07-13 17:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1840400 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:41:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
bug screenshot (223.95 KB, image/png)
2020-05-26 07:05 UTC, XiaochuanWang
no flags Details
Verification screenshot (250.76 KB, image/png)
2020-05-27 01:57 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5562 0 None closed Bug 1839977: correctly link to OperatorGroup from CSV details 2020-06-22 05:09:19 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:41:45 UTC

Description XiaochuanWang 2020-05-26 07:05:15 UTC
Created attachment 1692153 [details]
bug screenshot

Description of problem:
User install an operator such as Metering, check the operator detail page after installation succeed. The Operator Group lost link 

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-25-052746

How reproducible:
Always

Steps to Reproduce:
1. User install an operator such as Metering under 'openshift-metering' namespace.
2. Go to the operation detail page after installation succeed, scroll down to "ClusterServiceVersion Details" and check the "Operator Group"


Actual results:
Operator Group lost link for openshift-metering-swwcb

Expected results:
Operator Group should link to k8s/ns/openshift-metering/operators.coreos.com~v1~OperatorGroup/openshift-metering-swwcb

Additional info:
Please refer to the bug screenshot

Comment 2 bpeterse 2020-05-26 14:56:48 UTC
Tide is running the second pass on tests, this should merge soon.

Comment 5 XiaochuanWang 2020-05-27 01:57:55 UTC
Created attachment 1692497 [details]
Verification screenshot

Comment 6 XiaochuanWang 2020-05-27 01:59:02 UTC
This is verified on 4.5.0-0.nightly-2020-05-26-224432 (please refer to the screenshot)

Comment 7 errata-xmlrpc 2020-07-13 17:41:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.