Bug 184017 - The Add/Remove aplet crashes. It is unable to process the list of installed software.
The Add/Remove aplet crashes. It is unable to process the list of installed s...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 184018 184019 184020 184021 184022 184023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-04 21:06 EST by Donald B. McAlister
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 11:32:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald B. McAlister 2006-03-04 21:06:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; TaxWise20.02[0003]; .NET CLR 1.0.3705; .NET CLR 1.1.4322; Media Center PC 3.1)

Description of problem:
The add/remove software aplet is unable to retreive the information about installed software. It reports an unhandled exception: 
Component: Software manager 
Summary: TB86fdcb55 repos.py 431:check: Repo Error: Cannot find a valid base for repo: development

Version-Release number of selected component (if applicable):
pirut -0.9.10-1

How reproducible:
Always

Steps to Reproduce:
1.Press "Add/Remove Software" under the Applications menu
2.The package manager window opens and the aplet begins to search for software. 
3.It crashes producing an exception window with the message above
  

Actual Results:  See above

Expected Results:  List of installed software and the opportunity to add or remove software.

Additional info:

I reinstalled the Fedora Core in case there was an installation error. Same result!
Comment 1 Rahul Sundaram 2006-03-06 04:38:52 EST
*** Bug 184018 has been marked as a duplicate of this bug. ***
Comment 2 Rahul Sundaram 2006-03-06 04:38:58 EST
*** Bug 184019 has been marked as a duplicate of this bug. ***
Comment 3 Rahul Sundaram 2006-03-06 04:39:29 EST
*** Bug 184020 has been marked as a duplicate of this bug. ***
Comment 4 Rahul Sundaram 2006-03-06 04:39:47 EST
*** Bug 184021 has been marked as a duplicate of this bug. ***
Comment 5 Rahul Sundaram 2006-03-06 04:40:17 EST
*** Bug 184022 has been marked as a duplicate of this bug. ***
Comment 6 Rahul Sundaram 2006-03-06 04:40:26 EST
*** Bug 184023 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2006-03-06 11:32:55 EST
This is fixed in later versions
Comment 8 j_e_miller 2007-01-02 21:19:19 EST
I do not understand Bugzilla procedures, but the problem is similar:
reproducible as above; no problem before recent installation of software,
including KYum. 
   Component: Software Manager
Summary: TBfef41469 versionlock.py:45:exclude_hook:PluginYumExit: Unable to read
version lock configuration: [Errno 5] OSError: [Errno 2] No such file or
directory: '/etc/yum/pluginconf.d/versionlock.list'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 390, in ?
    main()
  File "/usr/sbin/pirut", line 386, in main
    pm.run()
  File "/usr/sbin/pirut", line 299, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 310, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 154, in reposSetup
    self.doSackSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 299, in doSackSetup
    self.plugins.run('exclude')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/versionlock.py", line 45, in exclude_hook
    raise PluginYumExit('Unable to read version lock configuration: %s' % e)
PluginYumExit: Unable to read version lock configuration: [Errno 5] OSError:
[Errno 2] No such file or directory: '/etc/yum/pluginconf.d/versionlock.list'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0xb348f38c>
e: [Errno 5] OSError: [Errno 2] No such file or directory:
'/etc/yum/pluginconf.d/versionlock.list'
locklist: []
location: /etc/yum/pluginconf.d/versionlock.list

Note You need to log in before you can comment on or make changes to this bug.