Bug 184030 - I still did not find a solution
I still did not find a solution
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 184032 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 00:28 EST by Paulo Silveira
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 09:35:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from Anaconda installer (858.75 KB, text/plain)
2006-03-05 00:28 EST, Paulo Silveira
no flags Details

  None (edit)
Description Paulo Silveira 2006-03-05 00:28:07 EST
Description of problem:
During the installation of Fedora Core 4 (using Anaconda) I got:

Assertion (head_size <= 63) at disk_dos.c:580 in function 
prob_partition_for_geom() failed
after clicking [ignore]
Assertion (sectors <= 63) at disk_dos.c:590 in  function 
prob_partition_for_geom() failed
after clicking [ignore]
Assertion ((C * heads + H) * sectors + S == A at disk_dos.c:593
after clicking [ignore]
The first message reappears...

After clicking [ignore] repeatdly, the same messages return a couple of times 
and then I can go to the partitions, following to the rest of the 
configuration normally.  At the end these messages return, the partitions seem 
to be created (the West HD seems unformated to Windows), but the installation 
aborts with the dumping I intend to attach here (as soon as I find how). I 
have tried to do the partitions automaticatically, manually, and deleting the 
old partitions (only in my second HD) as mentioned in bug <a 
href=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138419#c150>138419, 
comment #150</a>. 

My system is a HP Pavilion 514n with the original HD 60Gb (Samsung SV0602H). I 
added 512Mb RAM and a Western Digital 80Gb (WDC WD800JB) connected as 2nd 
slave (oddly, the Western HD could only be connected as slave in the first 
IDE; I couldn't find any combination of jumpers that could make it get along 
with the Samsung).

My plan is to maintain Windows while I learn how to use Fedora, for 
emmergencies.  I intend to install Fedora on the West HD and also put my data 
on it. I hope Windows will be able to "see" them, since it will be a FAT 32 
partition.  If this is possible, I can work under Fedora, but I can return to 
Windows if I get stuck. 

My CD-ROM/burner combo (PHILIPS CDD5301) is the 2nd master, from where I 
booted with the Fedora CD#1.

I am a Fedora first user, who is tired of Windows stuff (with which I have 
lived since the version 3.11). I had more than enough. Please, help me out of 
Windows!!! 

Thank you in advance.

How reproducible: Every time


Steps to Reproduce:
1. Boot with CD#1, Fedora Core 4
2. Starting installation with Anaconda
3. Accepting only partitioning of the second HD (the first has WinXP Home 
Edition)
4. Accepting all the other defaults
5. Start installation

Actual results:
Dump, saved to a floppy (attached to this report).

Expected results:
Fedora should finish installed on the second HD, having boot dual with WinXP 
on the first HD (which is partitioned by HP disk recovery)

Additional info:
I tried to submit this bug through the normal form, but Internet Explorer 6 
showed an script error in your page: Invalid sintax at line 228, character 13 
in https://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi
Comment 1 Paulo Silveira 2006-03-05 00:28:07 EST
Created attachment 125661 [details]
Dump from Anaconda installer
Comment 2 Paulo Silveira 2006-03-05 00:38:17 EST
It is duplicated in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=184032 because, after the submission of this report I received a message 
that "Product name is not valid. Go back and try again". I did, but then I 
realized that the report was created. 
Comment 3 Paulo Silveira 2006-03-05 00:43:37 EST
*** Bug 184032 has been marked as a duplicate of this bug. ***
Comment 4 Paulo Silveira 2006-03-05 00:48:12 EST
(In reply to comment #0)

I mispelled the error message. 
Where it appears:
   prob_partition_for_geom() failed
Read 
   probe_partition_for_geom() failed
Comment 5 Paulo Silveira 2006-03-05 08:10:55 EST
I disconnected the Western Digital from my computer, but I still got the same 
message. The weird geometry is coming from the Samsung HD, which has the HP 
partition and WinXP installed. Since this is the disk I intend NOT to touch, I 
do not understand why Anaconda refuses to install Fedora in this computer.

Is there a workaround if I disconnect the Samsung HD, plug the Western HD as 
master, install Fedora in it, and make a dual boot later? How? 

Could it be that the problem is the dual boot installer that is trying to 
modify /dev/hda? Anaconda says the dual boot information would be written 
there, but this hda has the HP factory partition that; from Windows, it is 
adviced to not touch it or else... :-)  There are two partitions: one is FAT32 
containing the "recovery" information, and the other is NTFS containing WinXP 
and my files.

I'm less than beginner in Linux - step by step instruction, please.
Comment 6 Chris Lumens 2006-03-06 09:35:47 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 7 Paulo Silveira 2006-03-06 14:59:19 EST
(In reply to comment #6)

Chris,

I found the bug 138419 before, and I also left a message there. I tried what is
recommended there, but it did not help me.  All the proposed workarounds there
"fix" the wrong partitions by deleting them. Well, I cannot do that for two reasons:

1. It is a HP Pavilion and the partition is made with HP recovery disks. When I
tried to install a regular Windows, the computer became unstable. There are some
special (and hidden) Windows adaptations that only HP knows.

2. Since I have a second HD in my computer, I do not intend to touch the HP
system.  Anaconda's bug, however, complains about this HD that I do not intend
to use, and is preventing me to install Fedora in the other.

Can someone help me out?

Note You need to log in before you can comment on or make changes to this bug.