Bug 184032 - Anaconda does not recognize HD geometry: function probe_partition_for_geom() failed during installation
Anaconda does not recognize HD geometry: function probe_partition_for_geom() ...
Status: CLOSED DUPLICATE of bug 184030
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 00:34 EST by Paulo Silveira
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 00:43:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dumping (858.75 KB, text/plain)
2006-03-05 00:34 EST, Paulo Silveira
no flags Details

  None (edit)
Description Paulo Silveira 2006-03-05 00:34:49 EST
Description of problem:
During the installation of Fedora Core 4 (using Anaconda) I got:

Assertion (head_size <= 63) at disk_dos.c:580 in function 
prob_partition_for_geom() failed
after clicking [ignore]
Assertion (sectors <= 63) at disk_dos.c:590 in  function 
prob_partition_for_geom() failed
after clicking [ignore]
Assertion ((C * heads + H) * sectors + S == A at disk_dos.c:593
after clicking [ignore]
The first message reappears...

After clicking [ignore] repeatdly, the same messages return a couple of times 
and then I can go to the partitions, following to the rest of the 
configuration normally.  At the end these messages return, the partitions seem 
to be created (the West HD seems unformated to Windows), but the installation 
aborts with the dumping attached here. I have tried to do the partitions 
automaticatically, manually, and deleting the old partitions (only in my 
second HD) as mentioned in bug <a 
href=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138419#c150>138419, 
comment #150</a>. 

My system is a HP Pavilion 514n with the original HD 60Gb (Samsung SV0602H). I 
added 512Mb RAM and a Western Digital 80Gb (WDC WD800JB) connected as 2nd 
slave (oddly, the Western HD could only be connected as slave in the first 
IDE; I couldn't find any combination of jumpers that could make it get along 
with the Samsung).

My plan is to maintain Windows while I learn how to use Fedora, for 
emmergencies.  I intend to install Fedora on the West HD and also put my data 
on it. I hope Windows will be able to "see" them, since it will be a FAT 32 
partition.  If this is possible, I can work under Fedora, but I can return to 
Windows if I get stuck. 

My CD-ROM/burner combo (PHILIPS CDD5301) is the 2nd master, from where I 
booted with the Fedora CD#1.

I am a Fedora first user, who is tired of Windows stuff (with which I have 
lived since the version 3.11). I had more than enough. Please, help me out of 
Windows!!! 

Thank you in advance.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Boot with CD#1, Fedora Core 4
2. Starting installation with Anaconda
3. Accepting only partitioning of the second HD (the first has WinXP Home 
Edition)
4. Accepting all the other defaults
5. Start installation
  
Actual results:
Dump, saved to a floppy (I intend to attached it to this report).

Expected results:
Fedora should finish installed on the second HD, having boot dual with WinXP 
on the first HD (which is partitioned by HP disk recovery)

Additional info:
I could not send this report with your normal form because Internet Explorer 
6.0.2800.1106 showed script error at line 228, character 13 in 
https://bugzilla.rehat.com/bugzilla/easy_enter_bug.cgi
Comment 1 Paulo Silveira 2006-03-05 00:34:50 EST
Created attachment 125662 [details]
Anaconda dumping
Comment 2 Paulo Silveira 2006-03-05 00:40:49 EST
I am sorry, but it is a duplicate from 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=184030. See why in 
addition comments there. 
Comment 3 Paulo Silveira 2006-03-05 00:43:15 EST

*** This bug has been marked as a duplicate of 184030 ***

Note You need to log in before you can comment on or make changes to this bug.